We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Printing doesn't respect to page layout

Hi,

The printing doesn’t respect to the page layout, I have uploaded an excel file with the page layout set as landscape and fit to page, but when it prints using the following code, it prints as portrait and no scaling. This is something works well before, and it doesn’t work in the build 8.2.1.4 we are using currently.

Please let me know if you have any question.

MyWorkBook = New Workbook(“C:\Users\wmeng\Desktop\ChartTest1.xlsx”)
Dim options As New Aspose.Cells.Rendering.ImageOrPrintOptions()
Dim pdlg As New PrintDialog
If pdlg.ShowDialog() = DialogResult.OK Then
options.PrintingPage = PrintingPageType.Default
wr = New WorkbookRender(MyWorkBook, options)
wr.ToPrinter(pdlg.PrinterSettings)
End If

Thanks,
Wei

Hi Wei,

Thanks for your posting and using Aspose.Cells.

Please download and try the latest version: Aspose.Cells for .NET 8.2.2 and see if it resolves your issue.

Please also let us know the older version which was working fine, so that we could compare the results of older and newer version. It will help us investigate this issue more precisely. If it is a bug, we will log it in our database for a fix.

Thanks for your cooperation.

I have tried the latest 8.2.2 build, the issue still exists. The build version we have no problem is 8.1.1.1.
I uploaded the printed copies using these two builds. You can see the difference.

Please let me know if you have any question.

Thanks,
Wei

Hi Wei,

Thanks for your posting and providing us the image highlighting this issue and using Aspose.Cells.

We were able to observe this issue after executing the following code using the latest and previous version. We found printing doesn’t respect to page layout in the latest version.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as

  • CELLSNET-43101 - Printing doesn’t respect to page layout.

I have attached the output PDFs generated by the Virtual Printer with the latest and previous versions.

C#

string filePath = @“F:\Shak-Data-RW\Downloads\ChartTest1.xlsx”;


Workbook workbook = new Workbook(filePath);


ImageOrPrintOptions options = new ImageOrPrintOptions();

options.PrintingPage = PrintingPageType.Default;


WorkbookRender wr = new WorkbookRender(workbook, options);

wr.ToPrinter(“doPDF v7”);

Hi Wei,

Thanks for using Aspose.Cells.

We have fixed
this issue now. We will provide you a fix in couple of days after
incorporating other enhancements and fixes and conducting some extensive
testing. Once, it is available for you, we will let you know asap by
posting in this thread.

Hi Wei,

Thanks for your using Aspose.Cells.

Please download and try the latest fix: Aspose.Cells for .NET v8.2.2.1 and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-43101) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.