We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Printing WordDocument to ActiveFax

Hello,

I have been trying to print word document to active fax server.

Active fax is an application used to send fax, there is a server, and a client, client install a printer on client computer, by printing document to the printer, client send to server the document to fax,

http://www.clubic.com/lancer-le-telechargement-430677-0-activefax-server-1.html

You can add datafield to word document in activefax font to add info that application will use to send the fax.

example

@F211 +43 2732 73204 25@

Active fax is supposed to read this line and add it ass recipient phone number.

While printing directly from word it work.

If i load it into aspose.word.document and print it it doesnt work, program doesnt recognize the line, like if aspose was changing the font, what is strange is if i save the aspose document to disk, and then print this document from word, it work.

So its only happen while printing from aspose

I have attached the document

Sample of code not working…

Dim word As New Aspose.Words.Document("Sample.docx")
word.Print()

Hi,

Thanks for your inquiry. First off, please make sure that you’re using latest version of Aspose.Words i.e. 14.4.0. You can download it from the following link:

https://downloads.aspose.com/words/net

Secondly, your document uses “ActiveFax” font, please note that Aspose.Words requires TrueType fonts when rendering/printing documents, and most likely the problem occurs because the required font is not present on the computer you’re performing printing operation on or Aspose.Words cannot locate this font on this computer. I would suggest you please read the following article:

https://docs.aspose.com/words/net/specifying-truetype-fonts-location/

I hope, this helps.

Best regards,

Im gonna check if the font is installed on the server, because on the client it is.

The package install the fonts in %windir%\fonts and they are truetype.

I even tried copy them to c:\ and use setfontfolder, didnt work.

Have u managed to make it work ?

Hi Claude,

Thanks for your inquiry. Please zip and attach your “ActiveFax” font here for testing. We will investigate the issue on our end and provide you more information.

Please also try executing the code from the following article to be able to set Aspose.Words to look for TrueType fonts in system folders as well as a custom defined folder when scanning for fonts.

https://docs.aspose.com/words/net/using-truetype-fonts/

Best regards,

I already tried that.

I added the font installed by the installer of ActFax as attachments.

Thank you

Hi Claude,

Thanks for your inquiry. For the sake of any correction, I have logged this problem in our issue tracking system. The ID of this issue is WORDSNET-10214. Our development team will further look into the details of this problem and we will keep you updated on the status of correction. We apologize for your inconvenience.

Best regards,

Hello,

I found out that, if i specify the mergefield in the document name, Activefax can read them.

doc.Print(prs, "@F201 Smith Inc.@@F211 800-123-4567@@F307 This is a test fax@")

Hi Claude,

Thanks for the additional information. Its great you were able to find what you were looking for. We will also keep you informed of any developments on WORDSNET-10214.

Best regards,

Hi Claude,

Thanks for being patient. Regarding WORDSNET-10214, our development team has completed the work on your issue and has come to a conclusion that they won’t be able to implement the fix to your issue. Your issue (WORDSNET-10214) is now closed with ‘Won’t Fix’ resolution.

Correct TrueType font “ActiveFax” is used when Aspose.Words saves document to GDI+. Probably when Microsoft Word prints the document it uses printer internal font instead of installed TrueType font. Also, there is a note in “ActFax Server User’s Manual” which says:

As an alternative it would also be possible to embed data fields directly in the document (i.e. with WinWord). When using this method, it is important to format the data fields with the “ActiveFax” font. If you do not format data fields with that font, the data fields are ignored and printed as visible text on the document. Take care that the “ActiveFax” font is a printer in-ternal font and is only visible in the font selection window when the cur-rent printer has also been set to “ActiveFax”.

It is impossible to use printer internal fonts with GDI+ so we can’t do anything to fix this problem. As a workaround customer could try to use other printing options e.g.

I hope, this helps.

Best regards,