We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem opening Workbook created using Aspose Cells

The attached workbook was created entirely with Aspose Cells version 8.0.1.3. (.NET 3.5 version).



When opening it in Microsoft Excel the attached screen shots of errors are reported from Microsoft Excel.



Excel finds unreadable content in the Workbook.

Hi Michael,


We have checked your provided spreadsheet with Excel 2007 & 2010; both versions show similar error message regarding the “Unreadable Contents”. We are wondering what source code lines could have caused this behavior, therefore we would request you to please share the code snippets to replicate the generation of such spreadsheet on our end. If possible, please share an executable standalone sample application in an archive.

Thank you for your cooperation and understanding.

Hello Babar,

Again this is a bit problematic given the size of the application, databases required and configuration settings to set up our application.

Somewhere in your code it appears there is bad content being written to the Xlsx file, and callers into the Aspose library should be protected from this.

We have been trying to narrow it down so as to help your find the issue, but this has proved difficult also.

One thing we think may be causing it is cells with Centre Across Selection Formatting, but we are not 100% sure there.

Note, it wasn’t a problem prior to version 8.

Hope this helps you.

Regards,

Mike

Hi Mike,


We have tried to generate such a spreadsheet that could exhibit the similar behavior as of your provided file upon loading with MS Excel application, unfortunately we didn’t succeed. Although we noticed that Aspose.Cells for .NET 8.0.1.3 cannot load your provided spreadsheet, instead it throws an exception of type CellsException with message “Invalid cell name”. We have logged a ticket (CELLSNET-42599) against this exception and requested the development team to look further into this matter. Moreover, we have recorded that the spreadsheet was generated with Aspose.Cells APIs for through investigation.

Regarding the original issue, we need your help in identifying the problem cause. We would request you to please try replicating the issue with minimal source code lines, and without needing the database connectivity. Instead of pulling the data from database, you can hard code the dummy values, and provide an executable standalone sample application here for our review.

Looking forward to your kind response.

Hi Babar,

Thanks for investigating this issue. (And also the issue re Inserting Rows I also raised today)

This issue and the other I raised today re Inserting Rows and getting an Exception are real problems for us at the moment as we cannot move customers (from version 7…where things worked pretty well) to version 8 (which apparently picks up and fixes a lot of other matters we have previously raised (pre version 8) and have been fixed by you guys. We are more than keen to release those fixes, but can’t at the moment due to the issues we are currently having with version 8.

I can send you lots of Workbooks that we create with Aspose 8 entirely where this (unreadable content error from Microsoft Excel upon opening) issue happens when opening in Microsoft Excel. All these (via code Aspose created) Workbooks worked fine pre version 8…version 7.7.2 of Aspose Cells was our previous stable working release.

I fully appreciate how it is difficult to get to the heart of these issues without access to source code, reproducible code snippets et al; from both parties. We will endeavor to try and narrow these problems down (had no success there yet, but not for want of trying) and, if we can provide you with more targeted info to help you reproduce the issues, we most certainly will.

As fellow software developers we fully understand that finding the cause of the problem is the difficult bit; fixing it is the easy bit.

I’m not sure if Aspose can issue source code so as to enable developers like us to replicate (and thus debug) problems more easily? Some of our other partners like DevExpress allow this. Does Aspose have a policy regarding that, as I’m sure these issues once stepped through with the entire source code stack would be easy to find and fix.

If so, maybe we could explore that tactic if triaging and fixing this issue and also the issue with inserting rows becomes problematic and time lagged – i.e., we can’t get to the bottom of quickly.

Conversely, we would be happy to do so also; however as an end user application like ours, it is problematic to do this in terms of setting up an environment with multiple databases, config files, registry settings, other third party libraries, COM integration et al etc etc.

We really do need a solution to these issues asap, and will work with you guys as best we can to resolve.

As another suggestion, is it possible to retro fit your fixes (I’m of the understanding, only available now in version 8) for issues we have raised back into version 7? That is, can the Aspose Cells version 7 codebase be re-issued with bug fixes that now require version 8 but don’t impact on version 8…but will work equally well in version 7…???

Maybe this is an option that would suit us both well and also give you and us some time to thoroughly test version 8. I can give you a list of the issues that we have raised that Aspose have notified us that are fixed in version 8 that we would be happy to see retro fitted into version 7. I fully understand if this is not possible, but think it is worth mentioning as a probable solution until we can nail down the problems we are having with version 8.

Failing all that, I’d like to discuss with you setting up a virtual machine to place our application on, hosted by you, so that you could step though our problems when all else has failed. I’m very sure the bugs we find (particularly the couple we are talking about here) are very easily found and fixed, given all the appropriate code/information at hand.

We need to resolve these issues asap. We are willing to help you to do so in the best of mutual outcomes.

Babar, if you would like to discuss this, please give me a call on +61 4 930 20220. I know our time zones probably differ a bit, but please call, leave a return phone number if I’m not available, and I will most certainly get back to you.

I look forward to hearing from you, and again thanks for your help.

Best Regards,



Mike



Apologies if this (long) post is without formatting and paragraph spacing etc….seems to happen for some reason on the Aspose reply text box. I have attached a word doc to make it easier to read if so.

HI Mike,


Thank you for writing back.

We have raised your concerns to the development team, and we will shortly respond back with more details in this regard.

Hi again,


We have done some analysis of your both mentioned issues (CELLSNET-42599, CELLSNET-42596). We believe these problems are interrelated, and most probably caused due to one bug. We have found there are some invalid cells (duplicated) in your given spreadsheet (generated by your program with Aspose.Cells component) such as the cell AO29. For your other posted issue in reference to inserting rows, it should be caused by duplicated cells in one row as well. Unfortunately, by reviewing our component we cannot find what could be causing these problems. Therefore we would request you to please provide us the main logic to create this file, such as the operations of inserting/deleting rows/columns so we can try to reproduce the problem on our end. If possible, please pay more attention to the operations for rows/columns/cells around AO29.

Please note, more details will help us to figure out the issue much quickly.

Thanks Babar,

I have installed 8.0.2 and run against my code base and cannot reproduce these issues with that version of Aspose Cells. (My code base is the same as when I initially raised the issue).

I’m guessing that although these issues 42599 and 42596 were not specifically mentioned in the list of changes/fixes for 8.0.2, they have somehow been found and fixed, or related to some of the fixes specifically mentioned in the 8.0.2 release notes…???

Are you able to confirm…???

Cheers,

Mike

Hi Mike,


For your two issues, we are unable to confirm whether they have been fixed by the new version because we do not have test cases to reproduce the issue(s) even with old versions. We did fix many other bugs, maybe some of them had the same cause as of your mentioned problem, although we are not sure about that. Anyways, we think you can use the new version if it does not cause those issues any more. At the same time, if you can provide us the executable code to reproduce the issue(as we have requested in our previous posts) with the old versions, we will figure out the root cause and make sure your mentioned issues are resolved completely.