Free Support Forum - aspose.com

Problem printing pdf documents


#1

I have a system that adds a cover page to user generated pdf documents and then prints them in bulk. This works as expected 99% of the time, but we had a number of problems in the last round. When i download the document and print it myself i do not have the problems, only when it is printed through aspose.

The three problems i ran into are:

  1. When printing the the whole page looks zoomed more than the original. This is causing the font to look larger it is also changing the margins and the footer is falling off of the page. This document also has a number of embedded images. Some of them print as expected some are missing.
  2. The source document had special greek symbols like the delta triangle. When this was printed those symbols printed as boxes. To me this points to a font problem?
  3. The source document has a diagram with boxes, arrows and text. When this is printed the boxes and arrows are missing but the text shows and is still positioned as in the original.

The code I use to print is:
Aspose.Pdf.Facades.PdfViewer viewer = new Aspose.Pdf.Facades.PdfViewer(new Aspose.Pdf.Document(filePath));
viewer.PrintDocument();

I am using version 19.1.0 of aspose.pdf in my c# project.


#2

@clmckinley

Thank you for contacting support.

Would you please share narrowed down sample application along with source and generated files so that we may try to reproduce and investigate it in our environment. Moreover, please ensure that the fonts being used in PDF document are installed in your environment for flawless rendering.


#3

@Farhan.Raza Thanks for getting back to me. . None of the documents i have created demonstrate the problem so i am thinking it has to do with the original creation. I am working to confirm that i can release the offending documents or have the original authors create new documents that demonstrate the problem.

I will respond as soon as i know.

Thanks,
Logan


#4

@clmckinley

You might be facing a document specific issue so we need the files and a narrowed down sample application reproducing the problem. Please take all the time you need and get back to us as per your convenience.


#5

@Farhan.Raza I got approval to release the documents but they are moderately sensitive so i cannot post them to a public forum. Is there a way i could send them to you or your team privately? I have the documents that demonstrate the problem and a simple console app that shows the problem.

Thanks!


#6

@clmckinley

Please note that all forum attachments are accessible to thread owners and Aspose staff only. Or any thread can also be marked as private if some public download link is to be shared. Sharing the link via private message is also a safe option which you have opted. Thank you for the data, we are looking into it and will update you soon.


#7

@Farhan.Raza
Thanks, I look forward to hearing what you find.


#8

@clmckinley

Thank you for being patient.

We will be updating you with our findings soon.


#9

@clmckinley

We have worked with the data shared by you and there are three files which are printed by shared console application.

From source folder:

  • diagram.pdf is printed as PDF Document1.pdf
  • margin and image problems.pdf is printed as PDF Document1.pdf
  • Symbols.pdf is printed as PDF Document1.pdf

PDF Document1.pdf
PDF Document2.pdf
PDF Document3.pdf

We have been able to notice third issue with diagrams. However, would you please list down name of PDF file, page number and the difference you notice so that we may address all of your concerns accordingly.


#10

Below are pictures that show what i see when i open the documents vs what is printed

diagram example.jpg (134.7 KB) - Note the missing diagram
margin and image problems example.jpg (342.3 KB) - note the missing images screwed up margins. It actually looks like the whole page is “zoomed”

The symbols.pdf was showing the “missing char square” in place of the symbols throughout but the first paragraph had 3 symbols that showed the problem. I just tried to reprint it to create an example and this time it appeared to work as expected. Resaving the source document appears to fix the problem so it is possible i inadvertently saved over my example fixing the problem.

A different question:

  • Is there anyway to tell aspose just to not print the whole document but instead to print just one or a subset of pages?

#11

@clmckinley

Thank you for elaborating it further.

We have logged below tickets in our issue management system for further investigations and resolution.

PDFNET-45999: Problem with Figures while printing PDF documents
PDFNET-46000: Problem with Margins and Images while printing PDF documents

Moreover, specific or selected pages of a PDF document can be printed with below code snippet:

System.Drawing.Printing.PageSettings pageSettings = new System.Drawing.Printing.PageSettings();
System.Drawing.Printing.PrinterSettings printerSettings = new System.Drawing.Printing.PrinterSettings();
printerSettings.PrinterName = "{printer-name}";
printerSettings.PrintRange = System.Drawing.Printing.PrintRange.SomePages;
printerSettings.FromPage = 5;
printerSettings.ToPage = 10;
using (var asposeDocPrinter = new Aspose.Pdf.Facades.PdfViewer())
{
    asposeDocPrinter.BindPdf(@"Input.pdf");
    asposeDocPrinter.AutoResize = true;
    asposeDocPrinter.AutoRotate = true;
    asposeDocPrinter.PrintPageDialog = false;
    asposeDocPrinter.PrintDocumentWithSettings(pageSettings, printerSettings);
}

We hope this will be helpful. Please feel free to contact us if you need any further assistance.


#12

@Farhan.Raza

Thanks for this update.
Does that mean you were able to reproduce the problems?
Assuming so what are the next steps and timeline for a resolution?


#13

@clmckinley

We have been able to reproduce the problems with latest version of the API so respective tickets have been logged in our issue management system for further investigations and resolution. They are currently pending owing to previously logged and critical tickets and may take some months to resolve.

However, we also offer Paid Support, where issues are used to be investigated with higher priority. Our customers, who have paid support subscription, report their issue there which are meant to be investigated urgently. In case your reported issue is a blocker, you may please consider subscribing for Paid Support. For further information, please visit Paid Support FAQs.


#14

@Farhan.Raza
Is there anywhere that i can track the progress of this bug? If are there any updates?


#15

@clmckinley

Thank you for getting back to us.

We are afraid PDFNET-45999 and PDFNET-46000 have not been scheduled yet. Moreover, you may not access our internal issue tracking system so you may request for issue progress in this thread where we will also notify you as soon as these tickets will be resolved.