Free Support Forum - aspose.com

Problem with IBM JDK JIT compiler

Hello,

I've been facing problems with Aspose Cells on IBM WebSphere for some time:

http://www.aspose.com/community/forums/208889/exceptions-on-ibm-websphere/showthread.aspx#208889

Looks like I've finally found source of those problems. JIT compiler breaks the code with some optimalizations / native code translation.

Great article about troubleshooting JIT is here: http://download.boulder.ibm.com/ibmdl/pub/software/dw/jdk/diagnosis/diag60.pdf

Chapters 5 and 26.


I've created some test project - see attachment. In src/main/java/cz.tigra.test.TestMain.java is source code of test. In folder /jar is compiled application. There is batch file run.bat with various configurations of JIT. You should change path to IBM JDK java executable.

run.bat will create 5 files. testJIT_normal.xls is only file, that has valid data (because this program don't reach treshold for JIT compiler) - other files have corrupted numbers (valid is 0.1, 0.2, 0.3 ... 50). With some JIT configurations, exception is thrown on method worksheet.getPageSetup().setPrintTitleRows(). This is not only method which fails in our application - it's only example.

My output of program is in attached output.txt.

You should probably run all your tests with IBM JDK with parameter -Xjit:count=0 (override JIT compiler treshold) to see all failing methods.


There is temporary workaround for this problem: disable JIT for Aspose Cells by this JVM parameter -Xjit:exclude={com/aspose/*}

But better will be if you contact IBM JDK Service team so they can fix this issue in JIT.


Thanks

Hi,

Thanks for providing us details with sample project.

We will evaluate it and get back to you soon.

Thank you.

Hi,

For your issue with IBM JDK, Please try our new version 2.2.0:

http://www.aspose.com/community/files/72/java-components/aspose.cells-for-java/entry233107.aspx

We have tested it with your test project and it works fine.

Thank you.

Hi,

It seems to be working.. I´ll try this in production environment.

Thanks