Problem with new PDF conversion method and Wingdings 2 font

Using the new Word to PDF conversion method, we’re having the same problem exposed here
On some server configuration (seems to depending of the OS language), we can’t produce PDF with checkbox characters (we use Wingdings 2 font).
With the old method, to correct this problem we use these parameters :

pdf.IsImagesInXmlDeleteNeeded = true;
pdf.IsTruetypeFontMapCached = false;
pdf.TextInfo.IsFontEmbedded = true;
pdf.TextInfo.IsUnicode = true;

But now we don’t know how to set these parameters ?
The new method is more efficient than the older one, so we would like to keep it.

Thanks for your request. Could you please attach a sample document for testing? I will try to reproduce the issue on my side and provide you more information.
Best regards.

Try to convert to PDF the attached document, and try different regional and languages settings (try also combobox in advanced tab).

Thank you for additional information. I managed to reproduce the problem and created new issue #7361 in our defect database.
Regarding ComboBox, do you mean Form Field? I tried to convert document that contains ComboBox form Field and all works fine. Please share the document that demonstrates the problem.
Best regards.

No I am talking about the combobox in windows configuration panel “Regional and languages options”, in the tab “Advanced”.
But if you have reproduced the problem it’s ok.

The issues you have found earlier (filed as 7361) have been fixed in this update.

This message was posted using Notification2Forum from Downloads module by alexey.noskov.

I still have the problem with the attached file.
I’m using the new PDF convertion method and last version of Aspose.Words.
Please ir’s very important for us to have a quick fix for that because :
- it’s a regression.
- old method is no more working too.


Thanks for your request. The problem does not occur on my side (see the attached PDF document). Please make sure that Wingdings 2 font is installed on the PC where you perform conversion to PDF (I also attached Wingdings 2 font).
Best regards.

You were right, that’s because the server didn’t have Wingdings 2 font installed.
Works in both mode right now.
Note that :
After installing the font, old method works, for new method I’ve had to restart the server and now it works too.