We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem with paragraph indentation when followed by list

Greetings,

We have a strange bug with Aspose.Words where html is inserted into the document (insertHTML) and a paragraph is followed by a list (ul,ol) you will find the paragraph will have a slight indent. Only if it is followed by a list though. We have tried versions from 9.8 all the way up to 10.5. None of the releases seem to fix the problem. Could you please let me know if this is by design or a layout issue?

If you export to word you outdent the paragraph and then it lines up with the rest of the document. So there is some formatting issue as the cause, I just cannot figure out what the problem is.

Your help is appreciated.

Hello
Thanks for your request. Could you please show me your code and attach your input and output documents here for testing. I will check the problem on my side and provide you more information.
Best regards,

I have attached an example project so you can see exactly what I am doing. There are some default styles being applied to the list elements and those styles are propagating to the immediate preceding element. In the example you will see that both a hr and a p will have a margin if the list element has a margin, even though there are no styles that affect p or hr tags. Thanks in advance.

Hi
Thank you for additional information. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is resolved.
Best regards,

Any chance we can get an ETA on when this might be fixed?

Hello
Thanks for your inquiry. At the moment this issue is pending for analysis. The responsible developer will analyze the issue and we will be able to provide you an estimate.
Best regards,

Greetings, I’ve noticed a new version available (10.6) but do not see the issue above as one of the fixes in the new build. This is a government client which is encountering this problem and will not be content with an extended wait to have this issue fixed. Can we please have some definitive timelines on when this issue will be resolved? Thanks in advance for your time.

Hello
Thanks for your inquiry. As I mentioned earlier, at the moment this issue is pending for analysis. The responsible developer will analyze the issue and we will be able to provide you an estimate. Sorry for inconvenience.
Best regards,

Sorry to bother you again, but we’re at a month since I’ve first presented the issue. To date I have not received word from your developer on when this issue will be estimated, not to mention fixed. You have stated that the developer will take a look at the issue and you would let me know from there what to expect. As an OEM developer who has sank a considerable amount of money into your product I would appreciate some sort of response other than the canned reply that the developer will look into things.

I look forward to getting some concrete timelines on when this issue will be addressed. Thank you in advance.

Hi
Thanks for your request and sorry for inconvenience. Unfortunately, the responsible developer did not have time to analyze the issue yet. I contacted him directly and he assured me he would take a look at this matter shortly. Once he get back with more information regarding this issue, I will immediately let you know.
One more time I apologize for inconvenience.
Best regards,

Thanks for getting back to me.

Hi,

I’m working on the issue. Unfortunately, it will not be resolved in upcoming November release, but it’s in progress.

Hey guys, getting close to 2012, any chance we might get this resolved this year?

Hello
Thanks for your request. Unfortunately, the issue is still unresolved, but it’s in progress. And currently, I cannot promise you that the issue will be fixed before the next hotfix. Sorry for inconvenience.
Best regards,

Hey guys, been a while. Any word on when this may be fixed?

Hi Redengine,

Thanks for your inquiry. Unfortunately, your issue is in analysis process. Once our developers analyse this issue, we will be able to
provide you an estimate. You will be notify as soon as it is fixed. Sorry
for inconvenience.

I’m pretty sure that waiting from October until now is a little more than an inconvenience but please let us know whenever your analysis is complete.

Hi Redengine,

Thanks for your inquiry. Please find status information below:

Status: In Analysis
Resolution: Unresolved
Fix Version/s: 11.3.0-Apr 2012

Moreover, We are unable to commit any time estimate because this feature is still Unresolved. We will let you know once this feature is supported.

The issues you have found earlier (filed as WORDSNET-5382) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.