Problem with Printing


#1

Hi,

I have downloaded the Aspose.words and Aspose.pdf.kit. I want to do the following in our application:

  1. Do mail merge on a word template document using Aspose.words




  2. Convert the word document to pdf

    code:

Aspose.Words.Document oADoc = new Aspose.Words.Document(@“C:\Documents
and
Settings\parthasarathyt\Desktop\MyDinner Invitation.doc”);

oADoc.Save(@“C:\pdfdata.xml”,Aspose.Words.SaveFormat.FormatAsposePdf);

Aspose.Pdf.Pdf pdfDoc = new Aspose.Pdf.Pdf();

pdfDoc.BindXML(@“C:\pdfdata.xml”,null);

pdfDoc.Save(@“C:\Documents and
Settings\parthasarathyt\Desktop\MyDinner.pdf”);


3. Print the pdf document using Aspose.pdf.kit

code:

Aspose.Pdf.Kit.PdfViewer pdfvwr = new Aspose.Pdf.Kit.PdfViewer();

pdfvwr.OpenPdfFile(@“C:\Documents and
Settings\parthasarathyt\Desktop\MyDinner.pdf”);
pdfvwr.PrintDocument();

pdfvwr.ClosePdfFile();


In fact I used the “Dinner Invitation” merge demo available with Aspose.words for doing this.

The first 2 steps worked perfectly - but the third printing step is not
as expected. The pdf document pages gets cut by half vertically and
horizontally in a A4 page while printing. However, if i open the pdf
document using acrobat reader and print it, the printing comes
out fine.



Can someone tell me what i am doing wrong here?



Thanks in advance,

Sarathy



#2

Thanks for considering Aspose.

Please attach document MyDinner.Pdf, we want to have a test to find what cause this problem.


#3

Thanks for the quick response

Attached is the pdf I tried to print.

One more doubt - How can we change print setting while printing using pdfviewer. Is there anyway in which I can do this using any of the aspose products?

Thanks,

Sarathy


#4

Thanks for considering Aspose.

I've reproduced your error and will try to fix it up ASAP.

BTW, there is a method of Class PdfViewer called PrintDocumentWithSetup which pops up a dialog box for printing settings. You can call it instead of method PrintDocument.


#5

Thanks Kevin,

We won’t be able to use printdocumentwithsetup because printing has to happen without user interference.

I am evaluating aspose as a replacement for word in the server. Right
now we merge and print using word automation. I was trying to do the
same using aspose.words - apparently the documentviewer in aspose.words
is in beta stage so I could not use it for printing. I think converting
to pdf and printing using pdf.kit is the next best option. let me know
if you think otherwise.

And also let me know how I can keep myself updated about the fix for this issue.



Thanks

Sarathy



#6

Thanks for considering Aspose.

We have tested your pdf file. It is our bug in decoding the fonts. We will solve it very soon.


#7

I've run into this same issue with the latest release. What is the status of this bug? Thanks.


#8

Thanks for considering Aspose.

Our developers are now trying to get this bug fixed and provide functional progress as well. So it still need more days to accomplish.


#9

Actually we have the same problem but we just don't bother and we use Acrobat Reader to print instread.

Would be great if you guys can get it fix as soon as possible as well because Acrobat Reader is not a good options for us as we need to install the Reader and to send to print as Command.

Please update us if this problem is solved.

Thanks in advance.


#10

OK, We will notify you when this problem is solved.


#11

Other than the problem in fonts, can you provider the function of sending the print job to a different printer than the default printer?

Thanks.


#12

Thanks for considering Aspose.

We will take this feature into account but can not support it in a short time.