Problem with "Could not load type 'Aspose.PowerPoint.WFVB.Template.Global'"


#1

Greetings!

We just purchased Aspose. Since we're ASP and .NET programmers here only, we created a virtual file on IIS that points to the Aspose WFVB file on the server's C drive, but we get this error message on the browser:

Server Error in '/Aspose.PowerPoint.WFVB.Template' Application.

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load type 'Aspose.PowerPoint.WFVB.Template.Global'.

Source Error:

Line 1:  <%@ Application Codebehind="Global.asax.vb" Inherits="Aspose.PowerPoint.WFVB.Template.Global" %>

Source File: C:\Program Files\Aspose\Aspose.PowerPoint\Demos\WebForms\Template.VB\global.asax Line: 1


Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032

Can anyone help? It's pretty bad when we can't even view the demo on our Web server! Thanks.


#2

Did you try to compile project?


#3

No. We didn’t know Aspose required a compiler to deploy it. Thanks.


#4

Since we're not using Virtual Studio or a compiler currently, any suggestions on how we can get the demo to work on our IIS server? Thanks.


#5

I have compiled project. Please check attached zip.



Also you can test it online.

http://www.aspose.com/Products/Aspose.PowerPoint/Demos/

“General Demo” -> “Create Simple presentation from template


#6

Thanks for that.

I placed those files in the Template.VB file and now the error message is:

"Could not load 'Aspose.Powerpoint.WFVB.Webform1.'"

???


#7

Just tried to do it.

  1. Create directory “C:\Inetpub\wwwroot\test”
  2. Copy all files from archive to this directory.
  3. In the “Internet Information Service” settings create application “test” for this directory.
  4. Open page “http://localhost/test/Default.aspx” in explorer.

#8

Just need to check…when you say “all files from the archive,” do you mean just the files in the ZIP file? Thanks.


#9

Sure, only files from archive and nothing else.


#10

Thanks for the prompt reply.

It might help to let you know that our Web Server (IIS) has the usual system files in the C: drive and the actual Web files in a I: drive...not an unusual setup. The Aspose files from the original download and install were to the C: drive. Should we reinstall Aspose and have the files go to the I: drive?

I ask this because I did as instructed and, alas, once again, got the initial error message on this thread.

Thanks again for your help, BTW, we're determined to get Aspose running.


#11

An update: I tried the re-install on the I drive and the Aspose tool still brings up the error message quoted above. We’re at a standstill now and we would really appreciate some help.


#12

If you have web server installed on I drive and have folder I:\Inetpub then copy files to

I:\Inetpub\wwwroot\test and do all other things as I wrote before.



Or copy files from archive to any folder and create virtual directory.

It will work too.


#13

Thanks. We’re going to try that again.


#14

UPDATE: We just talked to an Aspose user, Randy Kemp.

He suggested that rather than go with the virtual Web folder route, that we instead create a reference to the Aspose .DLL and then reference it as a namespace in VB.NET coding--he said that should evoke the Aspose .DLL with no errors.

He said he does this and it work fine for him.

We'd appreciate any tips on doing this. As we've said before, we're rather new to DOT.NET.

Thanks again.