We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem With Setting/Getting Combobox Value Via FillField

I ran into some problems when I tried to set the value of a combobox using FillField method.

I need to be able to set the combobox value programmatically and retrieve that value later.

Eg: I have a combobox with items [{“Option 1”, -1}, {“Option 2”, 0}, {“Option 3”, 1}].
If I call FillField(“ComboboxName”, “0”), it will select the second item in the list (as expected).
However when I try to access the pdf later and try to read the value of the combobox using GetField(“ComboboxName”), it will return “Option 2” instead of 0. But, if I open up the pdf and manually selection “Option 1”, save, then manually select “Option 2”, then save and run GetField, it will return 0 (expected value).

I believe the problem lies with FillField setting the wrong value.
It’d be great if I can get some help with this.

I attached a sample .net 4 console application.
I used VisualStudio 2013 and Aspose PDF 9.6.0.0

Thanks!

Hi Sung,


Thanks
for using our API’s.<o:p></o:p>

I have tested the scenario and I am able to reproduce the same problem. For the sake of correction, I have logged it in our issue tracking system as PDFNEWNET-37511. We will investigate this issue in details and will keep you updated on the status of a correction.

We apologize for your inconvenience.

Can you suggest any workarounds for this issue?


If there’s a way to get the list of values inside the combobox I can just search through that list and get the value manually, but I haven’t been able to find anything related to that.

Hi Sung,


I am afraid currently we cannot share any workaround but as soon as we have some updates regarding the resolution of this issue, we will be more than happy to update you with the status of correction.

The approach which you are using in readComboValues() method is correct for getting form field values. However you may consider using Document Object Model (DOM) approach of Aspose.Pdf namespace and see if it can resolve this issue. For further details, please visit Get Values from all the Fields of PDF Document

It’s been roughly a year, what attention has been put toward this issue in that time? We need a fix for this as soon as possible, or at a minimum a technical reasoning as to why this does not work!

Hi Sung,


Thanks for your patience and sorry for the delayed response.

I am afraid the above stated issue is not yet resolved but I have shared your concerns with development team and have requested them to share the possible ETA. As soon as the investigation task is completed, we would be in a position to share any possible ETA. Your patience and comprehension is greatly appreciated in this regard.

The issues you have found earlier (filed as PDFNEWNET-37511) have been fixed in Aspose.Pdf for .NET 11.0.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.