We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem with smartmarkers and formatting cells

In the template.xls attached I have 3 different ways to display the same information from a datasource. An example of the output can be found in output.xls.

The first table shows the data vertically. Here the result is as expected and correct, all formatting of the cells is duplicated with each new line added.

The second table shows the data horizontally. The third table shows the data expanded to more than one line for each row of my datasource. In both cases I had to add the "noadd" smartmarker option to get the results I want. But in both cases only the data is added for each new row, and format information is not duplicated to the new rows. I need my format settings to be copied also : the bold formatting for the name, the date format setting for my creationdate and the number format for my composition_max... What has to be done to get the formatting options copied from the first row to each of the next rows ? Surely there must be a way to do this automatically.

Best regards,

Hemmis

Hi,

Thanks for providing us the template files.

Well, when you use smart markers (vertically) the formattings would also be applied to all data rows. We will look into it and support to apply formattings for those smart markers which are placed horizontally in the worksheet cells. I think, currently, you may apply the style formattings after the markers are processed and filled with data into the cells.

For applying formattings, kindly check the doc links:

http://www.aspose.com/documentation/file-format-components/aspose.cells-for-.net-and-java/approaches-to-format-data-in-cells.html

http://www.aspose.com/documentation/file-format-components/aspose.cells-for-.net-and-java/setting-display-formats-of-numbers-dates.html

http://www.aspose.com/documentation/file-format-components/aspose.cells-for-.net-and-java/dealing-with-font-settings.html

Thank you.