We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem with Spell Check feature in aspose.word(5.2.2.0)

Hi Aspose,

This is regarding the inconsistent working for spell check feature of aspose.word across different versions. We have used aspose.word-5.2.2.0 dll in our project and generating a word document. We have used a template(TableTemplate_0.doc) consisting of tables with rows and columns which is loaded into the aspose.word document. After the word document is generated, when we open the document in Microsoft word 2007 and use the spell checker, the spell check feature is not identifying the misspelled word. See the Screen Shot (Spell_check.jpg) attached for the same, which shows no error even though there are misspelled words.<?xml:namespace prefix = o ns = “urn:schemas-microsoft-com:office:office” />

Then we tried with aspose.word 4.2.0.0 dll to generate the word document with similar code, contents and generated the document. In this case, the spell check feature of Microsoft Word 2007 identified the misspelled word.

I have attached both the projects with 4.2.0.0 word dll used (Aspose4.0) and another project with 5.2.2.0 dll (Aspose5.2.2.0) used.

I tried with the latest Aspose word dll of version 8.0.0.0, but even then we are getting the same results, So can you please provide the solution for the problem as early as possible.

Regards

Pavan Kumar

Hi

Thank you for reporting this problem to us. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is fixed.

Best regards,

When do you think Aspose can fix this problem and provide us with an updated DLL? We need to know a date since the same needs to be applied as a fix to one of our production releases.

Thanks in advance.

Hi

Thanks for your inquiry. Currently it is difficult to provide you a reliable estimate regarding this issue. Please expect a reply before the next hotfix (within 4-5 weeks). We might just fix the problem by then or provide you more information.

Best regards,

Hi Andrey,

Do you have any updates for us on the above?

Regards,
Prashant

Hi Prashant,

Thanks for your request. Unfortunately, the issue is still unresolved. You will be notified as soon as it is fixed.

Best regards,

Hi,

Do you have any updates on the above issue. We have a production issue related to this. So when can we expect the solution.

Regards,

Ganapati

Hi

Thanks for your request. Unfortunately, the issue is still unresolved. I will let you know once there is something new regarding this issue.

I think, you can try using the workaround provided in the following thread:

Could you please try it and let me know how it goes on your side?
Hope this helps.
Best regards,

Hi

We tried work around mentioned in the other thread.“Set Language” preference manually works.Other way (Code) does not work.

Manual way we tried in MS Word 2007:

Select l text in the doc

Go to “Review”>“Set Language”

Uncheck “Do not check spelling and grammar”

Please suggest.

Regards

Ganapati Bhagwat

Hi

Thank you for additional information. Currently I cannot suggest you any way to work this problem around. You should just wait for the fix of the original issue.

Best regards,

The issues you have found earlier (filed as WORDSNET-1586) have been fixed in this Aspose.Words for .NET 17.6 update and this Aspose.Words for Java 17.6 update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(1)