We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Probleme with the zoom when export xlsx to html

Hi,
When in an xlsx file we change the zoom on each sheet, when we save as html the zoom is not preserved on the différents sheets.

In the zip file you have the code, the input document and the output document. aspose.zip (238.5 KB)

Thanks

@ISIWARE,

I evaluated your issue a bit via Aspose.Cells APIs using your template file. I guess you are talking about the last worksheet in the workbook whose zoom level is not retained (it sets zoom level to “60”) when viewing the output HTML in MS Excel. But when you open it in the browser (e.g. IE, Google chrome, etc.), its zoom level is retained. Do you find the zoom level issue with the last worksheet? Do you still want us to look into the issue even the output HTML is ok in the browser?

Hi,

The problem is actually on the last tab.
We want you to continue the diagnosis

Thank you Best regards

@ISIWARE,

Alright, we have logged a ticket with an id “CELLSNET-48312” for your issue. We will look into it soon.
The ticket is logged as following:
CELLSNET-48312 - Problem with the zoom level in XLSX to HTML export when viewing the output HTML in MS Excel

Once we have an update on it, we will let you know.

@ISIWARE,

This is to inform you that your issue has been resolved now. We will soon provide you the fixed version within the next few days after performing QA and incorporating other enhancements and fixes.

@ISIWARE,
Please try our latest version/fix: Aspose.Cells for .NET v21.7.7 (attached)
Aspose.Cells21.7.7 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.7.7 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.7.7 For .NetStandard20.Zip (5.6 MB)

1.Adds HtmlSaveOptions.WorksheetScalable property which indicates if zooming in or out the html via worksheet zoom level when saving file to html, the default value is false.
2.The sample code in .NET as follows:
Workbook workbook = new Workbook(filePath + “inputDocument.xlsx”);
HtmlSaveOptions options = new HtmlSaveOptions();
options.WorksheetScalable = true;
workbook.Save(savePath + “out.html”, options);

Your issue should be fixed in it.
Let us know your feedback.

The issues you have found earlier (filed as CELLSNET-48312) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao

Hi,
I’ve tried your solution in 21.8.0 and I’ve got the following problem
inputDocument.xlsx :
-Page 1 zoom 150%
-Page 2 zoom 70%
outputDocument.html :
-Page 1 it’s zoomed
-Page 2 I’ve got a white page.
In the zip file you have the code, the input document and the output document.Aspose.zip (199.2 KB)

@ISIWARE,
We have observed the issue and logged it in our database for further investigation. You will be notified here once any update is ready for sharing.

This issue is logged as:
CELLSNET-48312 - Problem with the zoom level in XLSX to HTML export when viewing the output HTML in MS Excel

@ISIWARE,

Please note, for managing issues accurately, we have created a separate ticket “CELLSNET-48711” to trace problem with the zoom 150% and 70% in XLSX to HTML export when viewing the output HTML in MS Excel. We will look into it to figure it out soon.

Once we have an update on it, we will update you here.

@ISIWARE,
Please try the latest fix 21.8.2
Aspose.Cells21.8.2 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.8.2 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.8.2 For .NetStandard20.Zip (5.6 MB)

The issues you have found earlier (filed as CELLSNET-48711) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao