Free Support Forum - aspose.com

Project.Read() Arithmetic operation resulted in an overflow

Hi,

I’m having issues opening a file with the latest Aspose Tasks that has worked on previous versions.

Error
Project reading exception.
Aspose.Tasks for .NET 4.7.0.0 version. Reading
project data in ‘MPP9’ format, created by ‘MSP2003’ started.
Arithmetic
operation resulted in an overflow.
at šˆ.‰ˆ.Read(Project , Stream ) at
Aspose.Tasks.ProjectReader.Read(Stream stream) at
NostraWWW.ProjectSchedule.InsertMilestone(String newFileLocation) in
C:\Dev\CPR\Bulwer Solution\NostraWWW\ProjectSchedule.aspx.cs:line 238

Code

// Set the license
License license = new License();
String path = Request.ServerVariables[“APPL_PHYSICAL_PATH”] + ConfigurationManager.AppSettings[“AsposeTaskLicense”].ToString();
license.SetLicense(path);

///Read mpp file from the server
ProjectReader rdr = new ProjectReader();

Project prj = null;

try
{
prj = rdr.Read(new FileStream(newFileLocation, FileMode.Open));
}


I’ve attached a condensed version of the file causing issues.

Cheers,
Peter

Hi Peter,


Thank you for writing to us.

I was able to observe the issue as you have mentioned. However, I have some observations here.

When I open your MPP file in Microsoft Project (MSP), the tasks don’t show at first in the Gantt Chart view until I expand them manually after which they become visible. If I save your MPP file with MSP in the same 2003 format without making any changes, then Aspose.Tasks open it successfully. It seems that the file has some issue. Can you please tell us if this Project was generated using Aspose.Tasks or through MSP?

Also, please share with us which version of Aspose.Tasks opened this file fine? as I tried uptil 4.6.0 version and it couldn’t be opened. We will look into this issue and try to assist you as soon as possible.

HI Kashi,

The project are maintained via MS Project, and Aspose.Tasks only reads them. The previous version we have been using for a number of years successfully is 1.6.3.0.

Cheers,
Peter

Hi Peter,


Thanks for your patience.

I have analyzed the data and have reproduced the issue here. I have logged this issue in our issue tracking system as TASKS-33257. You will be notified here on forum as soon as some feedback is received from the developers.

Hi Kashif,

Is there a work around for this at all as this is happening is a production system, and we need to get these Tasks read asap.

Cheers,
Peter


Hi Peter,


We are sorry for any inconvenience caused to you.

This issue is under consideration by the developers and they are working on it. I have passed your comments to the development team and will inform you as soon as some feedback is received.


Hi Peter,


I would like to update you about the status of this issue. As you can see from the status, we have fixed this issue and included it as part of our upcoming product release of Aspose.Tasks 4.9.0, which is due by the end of next week. You will be notified automatically once the release is in place. We appreciate your patience till then.

The issues you have found earlier (filed as TASKS-33257) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as ) have been fixed in this Aspose.Words for JasperReports 18.3 update.