We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Project Reading Exception - error when loading some files from the 2016 version

Hello Everyone,

I ran into a project reading exception today that seems very odd.
I am able to read MS project 2016 files normally. However, the last two I tried returned a project reading exception, and I can’t figure what’s wrong with my code, or my file.

Here are the description of the files I attached here in order to show the issue.

print1.png (7.7 KB) “print 1” shows exactly where I am having issues. Basically, the variable “projeto” reads the MS project file that is located in
a path provided by the variable “nome arquivo”.
Right after trying to read it, the exception is thrown.

print2.png (37.5 KB)
“print 2” shows the error that caused the code to throw the exception.

https://drive.google.com/file/d/0B7lcW54NL9GFUmxsSzlEQ2M0TUU/view?usp=sharing
Here is the .mpp file I am trying to read.

I have to say that I have tried other .mpp files from the same version and my code was able to read them normally.

I don’t think this is a version problem since I have updated my code to use a more recent version.

@arthustratec,

We regret the inconvenience caused to you.

We were able to reproduce the problem with the latest version of Aspose.Tasks for .NET 17.6 and have logged it as TASKSNET-2014 for further investigation by our Product team. We’ll update you here once there is some feedback or a fix version available in this regard.

1 Like

@arthustratec,

We have just released Aspose.Tasks for .NET 17.7 version where this issue has been fixed. Please download this latest version for testing at your end and let us know if we can be of any additional help to you.

1 Like

@kashif.iqbal Thank you so much, I really appreciate your help!
I downloaded the new version and already tested. It’s working fine now.

You are welcome.

Hey @kashif.iqbal,
Unfortunately the same error has appeared, in the same situation. This time with another .MPP file, of course.
Is there anyway you could analyze it? I don’t know what else I should try, the file seems fine.
Here is the file:
https://drive.google.com/open?id=0B01v3YMdUEYqbE1JVUdwRFhHMkE

@arthustratec,

Thank you for providing the sample MPP file. This issue is re-produced and logged under Id: TASKSNET-2109 for further investigation by the product team. You will be automatically notified once any update is received in this regard.

1 Like

@arthustratec,

This issue (TASKSNET-2109) has been fixed in latest version of Aspose.Tasks for .NET 17.9. Please let us know if we can be of any additional help to you with respect to your queries related to API.