Free Support Forum - aspose.com

Question mark diamond on HTML output

I am converting a test document from .docx to HTML. I am encountering an issue on the browser that can’t display double spaces. The word document is attached, and the rendered HTML displays the following image in Chrome after the sentence that says "This sentence has a double space after it."


http://www.log24.com/log/pix07/070702-Unknown.gif

What setting is there to prevent this unknown character from being output to HTML.

Thanks,
Troy

Hi Troy,

Thanks for your inquiry.

Perhaps you're using an older version of Aspose.Words; as with Aspose.Words for Java v13.1.0, I was unable to reproduce this issue on my side (please find attached the output HTML file). I would suggest you please upgrade to the latest version of Aspose.Words i.e. v13.1.0. You can download it from here.

In case the problem still remains and to ensure a timely and accurate response please supply us with the following information, if you cannot supply us with this information we will not be able to investigate your issue and raise a ticket.

  • What environment are you running on?
    • OS (Windows Version or Linux Version)
    • Architecture (32 / 64 bit)
    • Java version (JDK version)
    • Any Third Party Libraries / SDK in addition to Aspose Products
  • Please supply us with the code from your application that is causing the issue
  • Please supply us with the output HTML showing the undesired behavior

As soon as you get these pieces of information to us we'll start our investigation into your issue.

Many thanks,