Free Support Forum - aspose.com

Radar Chart toImage issue

I have ASPOSE.Cells for .NET 6.0.1. I am creating a radar chart and converting it to an emf image with the following code. While creating the chart I set the CategoryAxis.IsVisible value to False. The chart in the xlsx file looks correct, but the image is still showing the Category Axis Values. Am I missing something. I have attached the xlsx and a png. I am creating an emf in my code, but I could not upload that image and png had the same issue. I had done the same thing with a line chart with no issues. I have attached the xlsx document and the .png image. Thanks for your help. Here is my code.

Dim workbook As Workbook = New Workbook
Dim sheetIndex As Integer = workbook.Worksheets.Add()
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
Dim intLoop As Integer

worksheet.Cells(0, 0).PutValue(1)
worksheet.Cells(89, 0).PutValue(1)
worksheet.Cells(180, 0).PutValue(1)
worksheet.Cells(272, 0).PutValue(1)

worksheet.Cells(0, 1).PutValue(2)
worksheet.Cells(89, 1).PutValue(2)
worksheet.Cells(180, 1).PutValue(2)
worksheet.Cells(272, 1).PutValue(2)

'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(Aspose.Cells.Charts.ChartType.Radar, 3, 3, 20, 10)

'Accessing the instance of the newly added chart
Dim chart As Aspose.Cells.Charts.Chart = worksheet.Charts(chartIndex)

'Adding SeriesCollection for inner dots
chart.NSeries.Add("A1:A361", True)

'Adding SeriesCollection for outer dots
chart.NSeries.Add("B1:B361", True)

chart.ChartArea.Area.Formatting = FormattingType.None
chart.ChartArea.Border.IsVisible= False

chart.Legend.IsAutomaticSize = False
chart.Legend.Height = 0
chart.Legend.Width = 0

'Set min and max values
chart.ValueAxis.MaxValue = 2
chart.ValueAxis.MinValue = 0

'Value Axis Values
chart.ValueAxis.MajorGridLines.IsVisible = False
chart.ValueAxis.MinorGridLines.IsVisible = False
chart.ValueAxis.MajorTickMark = TickMarkType.None
chart.ValueAxis.MinorTickMark = TickMarkType.None
chart.ValueAxis.IsVisible = False
chart.CategoryAxis.IsVisible = False
chart.PlotArea.Area.Formatting = FormattingType.None
chart.PlotArea.Border.IsVisible = False

chart.NSeries(0).MarkerStyle = ChartMarkerType.Circle
chart.NSeries(0).MarkerSize = 8
chart.NSeries(0).MarkerForegroundColor = System.Drawing.Color.Black
chart.NSeries(0).MarkerBackgroundColor = System.Drawing.Color.Black
chart.NSeries(0).Line.IsVisible = False

chart.NSeries(1).MarkerStyle = ChartMarkerType.Circle
chart.NSeries(1).MarkerSize = 8
chart.NSeries(1).MarkerForegroundColor = System.Drawing.Color.Black
chart.NSeries(1).MarkerBackgroundColor = System.Drawing.Color.Black
chart.NSeries(1).Line.IsVisible = False

chart.ToImage("C:\radartest.emf", System.Drawing.Imaging.ImageFormat.Emf)
workbook.Save("C:\radartest.xlsx", Aspose.Cells.SaveFormat.Xlsx)

Hi,

Thanks for your post.

I was able to reproduce this bug using the latest version:
Aspose.Cells
for .NET v6.0.1.5



This issue has been logged as CELLSNET-29765.

Hi,

We have fixed this issue. Please download: Aspose.Cells for .NET v6.0.1.6

Thanks for the quick turn around. Is it posible to get this dll for .net 1.1? Most of our code base is still 1.1 and I would like to test it there also.

I did try the new dll in VS 2010. I removed the old files and replaced them with the new ones. I then deleted the old reference and added one to the new dll. I still get the same problem. is there something else I need to do?

Hi,

OK, we can provide you .NET 1.1 compiled fixed version for you requirement.

But, if you are using in VS.NET 2010, could you tell us what is the "Target Framework" set for your project in VS.NET 2010 (In VS.NET 2010, you may right-click on the Project (in Solution Explorer) and click Properties to check the target framework). For your information, the version/fix we attached (i.e. 6.0.1.6) is compiled on .NET 2.0 and it will work fine on the framework versions i.e.., 2.x, 3.0, 3.5, 4.0 etc.

Thank you.

the Target Framework is .NET Framework 4

I also just created a new project in framework 2.0 and copied the code over and used the referenced the version 6.0.1.6 Aspose.Cells.dll. I checked the version on the Aspose.Cells reference and it is the new version. Still seeing the issue in the image.

Just so you know all the steps that I did. Originally, I ran the Aspose.Cells.msi file to install all of the files. Then for the fix, I extracted the files out to the folder "C:\Program Files (x86)\Aspose\Aspose.Cells for .NET\Bin\net2.0" and replace the files that were in that folder with the three new files. Then I deleted the old reference to Apose.Cells.dll in my code and created a new one to the new dll. I did try to register the dll using regsvr32 tpo make sure it did not need to be registered, but it errored so it looks like that was not necessary. I am running 64 bit Windows 7 Professional SP1 if that helps.

I am not sure why I am not seeing the fix. Was there any steps that I missed?

Once you send the 1.1 version, I can test it on that as well.

Thanks for the help

Hi,

Please download: Aspose.Cells for .NET v6.0.1.6 (for Net1)

The issues you have found earlier (filed as 29765) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.