We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Re: Bold Face in Title Got Removed

Would you have an update on these fixes? Will it be available soon? You were expecting to have it ready by today.

Thanks.

Dear Kam,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please try the new version of Aspose.Slides 2.8.7.0. It has fixed most of the previous problems relating to bold/italic formatting getting lost or corrupted.

I upgraded to Version 2.8.7.0. I used it to produced a presentation that has 41 slides with embedded excel charts. I found this version only generated 10 slides and cut off the rest. If I remove the charts, I get further and got 20 slides but still with many missing.

I know just merely opening an existing template and saving it into a new ppt file does not cause this problem. I am trying to find out under exactly what situations this can happen, if you hear similar comments or perhaps already know about this, please let me know.

Thanks.

It appears that the Presentation.CloneSlide(…) in version 2.8.7.0 has some problems.
When I use the following problem to loop through a presentation to copy all the slides in a source presentation, it tells me that some object has null reference when every object has been instantiated.
Furthermore, I try another source ppt file and I have no problem. It appears this problem only present when I use certain input presentation ppt files. i.e., something in an input ppt files can cause an exception when I use the CloneSlide(…) method. Attached is one such ppt file that give me this problem. I do not have this problem with the version 2.8.4.0


Module Module1

Sub Main()
Dim license As License = New License
license.SetLicense("…/…/Aspose.Total.lic")

'Dim SourcePres As Presentation = New Presentation("…/…/input.ppt")
Dim sourcePres As Presentation = New Presentation("…/…/test.ppt")
Dim targetPres As New Presentation
copySelectedSlides(sourcePres, targetPres)
targetPres.Write("…/…/result.ppt")

End Sub

Private Sub copySelectedSlides(ByVal srcPres As Presentation, ByVal targetPres As Presentation)
Dim slidePos As Integer

For slidePos = 1 To srcPres.Slides.LastSlidePosition
Dim srcSlide As Slide = srcPres.GetSlideByPosition(slidePos)

If srcSlide Is Nothing Then
Console.WriteLine(“ERROR: encounter null srcSlide ref. Slide pos=” & slidePos.ToString)
Console.Read()
End If

Dim sList As SortedList = New SortedList()

If sList Is Nothing Then
Console.WriteLine(“ERROR: encounter null slist ref. Slide pos=” & slidePos.ToString)
Console.Read()
End If

If srcPres Is Nothing Then
Console.WriteLine(“ERROR: encounter null srcPres ref. Slide pos=” & slidePos.ToString)
Console.Read()
End If

If targetPres Is Nothing Then
Console.WriteLine(“ERROR: encounter null targetPres ref. Slide pos=” & slidePos.ToString)
Console.Read()
End If

srcPres.CloneSlide(srcSlide, targetPres.Slides.LastSlidePosition + 1, targetPres, sList)
Next
End Sub

I found another problem with version 2.8.7.0.

I am still losing the bold face format with some slides.

After I run the program below, the bold face format that the text on the right side of the chart is lost.

i.e., the input file, Infile.ppt has bold face in the text, result.ppt
does not have bold face. Both of these files are attached.





Sub Main()

Dim license As License = New License

license.SetLicense("…/…/Aspose.Total.lic")



Dim pres As Presentation = New Presentation("…/…/Infile.ppt")

pres.Write("…/…/result.ppt")

End Sub

Would someone please confirm if you see the same problems in version 2.8.7.0 (posted in the previous 2 postings) as I do? Thanks.

Yes, there are still problems in formatting, we will look into them and fix them as soon as possible.

Any news about the fix you are working on? When do you expect the fix to be available?

I have version 2.8.7.0 now.

Thanks.

Hello,

Everything works fine with latest build. So that means problem already fixed.
New version will be available on this week.

I just tried you version 2.8.8.0. The problem I pointed out on Aug 19 (reply #140434) is still there.
It cannot copy certain slides in a presentation. It would complain about null exception even when all objects have been instantiated.

I tried copy all slides from multiple presentations to make one big presentation. The application is not able to copy all the slides and exit silently without crashing. You replicate the situation by using the program and input file that I provided in my Aug 19 reply #140434.

When I switch back to version 2.8.4.0, I do not have this problem.

Would you please fix this ASAP as I have been waiting for a release that would fix all the issues pointed out in this series of messages.

Thank you.

Looks like a broken structure of the 6th slide.
2.8.4 and older version were not sensitive to this problem but for the right work of the last hot fixes
structure can’t have errors for correct copying portion and paragraph properties.

I will check if we can write workaround.
Anyway, it’s not possible to guarantee right slide cloning in this case.

I would appreciate a workaround on this. I am not sure what you mean by broken structure. I think you mean the graph has no good data in it. The reason is that the graph is an Excel object and we are using Apose.Cells’ Smart Designer Workbook feature to insert data into the embedded Excel worksheet. So the worksheet has only smart tags in it and good data would be replace tags later on in the application.

I would think many users of Aspose would like to do this to update a graph in a presentation…

I mean internal ppt structure of 6th slide.
I have published 2.8.9 hot fix. Please try it.
It doesn’t throw exception anymore.

I no longer have the problem. Thanks very much!