We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Re: Table border is lost when importing MHTML

Hi,

I am using Aspose.Email to first convert a mail to mhtml and then using Aspose.Words to convert to pdf. I see the table border are retained in the mhtml but when saving to PDF the table border is lost.

<table class=“MsoNormalTable” border=“1” cellpadding=“0” width=“800” style=“width:600.0pt;mso-cellspacing:1.5pt;border:solid black 1.0pt;mso-border-alt:solid black .75pt;mso-yfti-tbllook:1184”>

I am doing a AUTO_FIT_TO_WINDOW on the table before saving to pdf format.
Is this a known issue?

Hi Shyama,


Thanks for the additional information. Could you please attach your MHTML file, i.e. generated via Aspose.Email, here for testing? I will investigate the issue on my side and provide you more information.

Best Regards,

Hi,

Sorry for the delay. I am attaching the msg which was first saved as mhtml and then pdf. I see the table borders are present in the mhtml but they are lost when converting to pdf.

As mentioned earlier the table is set to auto fit,
table.autoFit(AutoFitBehavior.AUTO_FIT_TO_WINDOW);

Let me know if there is a workaround or fix for this issue.

Hi Shyama,


Thanks for your inquiry. While using the latest version of Aspose.Words i.e. 11.5.0, I managed to reproduce this issue on my side. I have logged this issue in our bug tracking system. The issue ID is WORDSNET-6616. Your request has also been linked to this issue and you will be notified as soon as it is resolved. Sorry for the inconvenience.

Best Regards,

The issues you have found earlier (filed as WORDSNET-6616) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.