We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Reading a PDF with Usage Rights Enabled

I am trying to read a PDF file with my Winforms App that has usage rights enabled, however, the Form object is being created with none of the fields showing.

When I create a Form object from a PDF with usage rights NOT enabled, it works fine. I understand you can’t populate a PDF with usage rights enabled, but can you load a PDF with usage rights enabled to grab data from the PDF fields that users have filled in?

Thanks,
Tom

Hello Tom,

Thanks for considering Aspose.

If you need to read data from usage rights enabled file, first you need to decrypt the file. For more information please visit Decrypt PDF Document.

You can Import and Export data from Pdf file in FDF, XML and XFDF format. For more information please visit

Import and Export into FDF

Import and Export into XML

Import and Export into XFDF

If it does not satisfy your answer, please feel free to contact.


I am not sure what you mean. I have gone ahead and decrypted the pdf file. I am then loading the file into a form object. eg:

Dim fileSecurity As PdfFileSecurity = New PdfFileSecurity(encryptedPDFPath, decryptedPDFPath)

fileSecurity.DecryptFile("")

Dim form As New Form(decryptedPDFPath)


DecryptFile() is returning true, but the form.fieldNames object doesn’t contain anything. If usage rights are NOT enabled, form will contain all the field objects. Why would I need to import/export into FDF, XML, or XFDF? I just want to access the field values from the decrypted PDF from the form object. Also, at no point in livecycle designer or acrobat am I setting a password. Does this make any difference? Any thoughts?

Thanks,
Tom

Hello Tom,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Sorry for causing the confusion in my previous post.

I suggested to use Import/Export into FDF,XML or XFDF, because you mentioned that you need to "load a PDF with usage rights enabled to grab data from the PDF fields that users have filled in?".

In order for us to understand this issue more clearly, please share the resource pdf file.


In this example, I want to open sample.pdf with VB.NET, then get the values “John Smith”, “Doctor”, and "John.Smith@mail.com".

I have been trying to do this by creating a Form object, passing “sample.pdf” into the constructor, then trying to access the field values by calling Form.getField().

e.g. something like:

Dim personalForm As New Form(“sample.pdf”)

Dim name as string = personalForm.getField(“nameField”)

Dim title as string = personalForm.getField(“titleField”)

Dim email as string = personalForm.getField(“emailField”)


(Note that nameField, titleField, emailField aren’t the actual field names on the PDF I provided, I am just using them as an illustration)

The problem is that when usage rights are enabled (as is the case with the attached PDF), I can’t access any of the values (they are null). The personalForm.fieldNames object doesn’t contain anything either. I have tried decrypting sample.pdf as you said, but that doesn’t help.

Hopefully that clarifies things.

Thanks,
Tom

Hello Tom,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

In order to read the contents of the form field, the name of the field must be same as specified during the creation of field. Also the field name is case sensitive.


As I said in an earlier post, when usage rights are NOT enabled, I can read the fields fine. When usage rights ARE enabled I can’t read them. I was just using those field names as an example. In my actual project, I am using the correct field names since it works with no usage rights enabled.

Any thoughts still?
Thanks,
Tom

Dear Tom,

Thanks for considering Aspose.Pdf.Kit.

Your requirement is to read field value with usage rights enabled, right? The problem you reported is reproduced and recorded as [PDFKITNET-6195], we will investigated into it, the ETA is about two weeks.

BTW, would you please tell me what usage rights are involved in? Printing? Filling? Commenting? Signing? or something else?

Thanks & Best regards.

Dear Tom,

I'm glad to inform you that this problem has been solved. The fix will be included in the coming release, which is about to published in the next month.

Thanks for your patience & Best regards.

The issues you have found earlier (filed as 6195) have been fixed in this update.