Free Support Forum - aspose.com

Reading Document

Hey all,

I just downloaded the evaluation version of the Aspose.Pdf and Aspose.Words because I would really like to convert some word documents into pdf.

I can't even do this:

Document myDoc = new Document("mydocument.txt");

an exception is thrown Aspose.Words.UnsupportedFileFormatException : Unknown file format.

What am I doing wrong? The file exists and inside that text file is a line with "qwerty" content

I've tried with .doc and .rtf extension and still no success.

I downloaded Aspose.Words v7.0 and Aspose.Pdf v4.1, I believe this error is caused only by Aspose.Words.

Please help

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. I cannot reproduce the problem on my side using the latest version of Aspose.Words (7.0.0). You can try using SaveToPdf method to convert your doc document to PDF. Here is the code:

Document doc = new Document("in.doc");

doc.SaveToPdf("out.pdf");

Please follow this link to learn more

http://www.aspose.com/documentation/.net-components/aspose.words-for-.net-and-java/loading-saving-and-converting.html

Best regards,

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Please see the following link to learn how to load plain text (TXT) documents:

http://www.aspose.com/documentation/.net-components/aspose.words-for-.net-and-java/howto-load-plain-text-txt-files.html

Hope this helps.

Best regards.

Hi Aspose Team,

thank you for the replies. I got it working now, I'm not 100% sure what happened, basically what I did was to recreate my .doc files, I thought since I was using Office 2003 it was not compatible.

Got it working with .doc and .docx now.

I can't do a direct convert but successfully converted the documents using the "Legacy Method" so for now I'll stick with that method since there is a possibility the client would like to manipulate the content before converting.

The plain text loading method is very useful thank you for that, I thought they are all treated equally as documents but apparently there is a different technique for plain text docs.

Very happy with this component!

Cheers guys!

Hello again,

I'm struggling with images in the document, not sure if this is because of the evaluation version.

I cannot save as PDF because it will thrown InvalidOperationException : Requested a name string that is not present in the font.

I've been browsing the forum and found that there are some people with this problem too simply because they use Chinese TTC font.

I'm only using the standard Arial font and it throws that error to me. I tried removing all text and leaving just the images and it works great.

Ultimately I tried this in a simple console application and does not work, the same error is being thrown

Document doc = new Document();

DocumentBuilder builder = new DocumentBuilder(doc);

builder.Writeln("Hello World!");

doc.SaveToPdf("myPdf.pdf");

I tried executing the code in different machines but no success. Tested machines:

- Windows XP Pro with SP2, Office 2003, .NET Framework 1.1 and 2.0 available

- Windows Server 2003 Standard Edition with SP1, Office 2003, .NET Framework 1.1 and 2.0 available

- Windows Vista Business with Office 2007, .NET Framework 2.0 available

I tried downloading the new Aspose.Words v8.0.0.0 and no success as well.

Can anyone help please?

- Alex

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. The problem might occur because Aspose.Words cannot read some of your fonts properly. Are there any additional fonts installed on your PC? If so, please attach these fonts here, if not, could you please archive all your fonts and share the archive somewhere. I will check all your fonts on my side and provide you more information.

Best regards,

Hi Aspose team,

Thank you for taking interest in investigating my case. I've attached the fonts that I had installed. There are some .otf and .ttc files.

The good news is my code now works on the production machine but does not work at all on any development and testing machines =(

It would be great if this could work on my development and testing environment though.

My next step would be to show this to my client using the demo version, then ask my superior to purchase the product.

I'm looking forward to get the full licensed of this component!

Kind regards,

Alex

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is resolved.

The problem occurs because Aspose.Words cannot read ARCHITIC.TTF font properly. As a workaround please try deleting this font from your PC.

Best regards,

The issues you have found earlier (filed as 11773) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.