We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Recalculation of project sets percent complete to zero on milestone tasks

Customers of ours have been reporting that milestone tasks (0 duration - often used for external dependencies like waiting on a permit) were losing their percent complete whenever they tried to load them into our system.


I downloaded the latest evaluation version and was able to reproduce the issue when calling Recalculate. Attached is a simple one line mpp with Percent Complete = 100%. After loading the file and calling recalculate, the value becomes zero.

var project = new Project(“milestone.mpp”);
var task = project.RootTask.Children.FirstOrDefault();
var originalPercentComplete = task.Get(Tsk.PercentComplete);
project.Recalculate();
var recalculatedPercentComplete = task.Get(Tsk.PercentComplete);


Is there a way to prevent this from happening?

Thanks

Hi Lou,


Thank you for contacting Aspose support team.

I have analyzed the sample MPP file and observed the issue. It is logged under Id: TASKSNET-1899 for further investigation by the product team.You will be automatically notified once any update is received in this regard.

Can I get an update on this issue?

Scott Elder

Hi Scott,


Thank you for contacting Aspose support team again.

I have checked the status of this ticket and observed that it is still not resolved and no ETA is available yet due to complexity of the issue. We will notify you here once any update is received in this regard.

The issues you have found earlier (filed as TASKSNET-1899) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.