Free Support Forum - aspose.com

Regression: Aspose.PSD 20.8.0 can't open file

Hi, the latest version has a regression in opening a psd file. I’ve attached the following:

  1. The code used to reproduce the bug.
  2. The input file
  3. The stack strace from the error.
  • The issue does not happen in 20.7.0 and earlier versions

This is very critical for us since this version fixes other problems which were reported by us but we can’t update the aspose.psd version because of this issue.

Thanks

sample.zip (4.3 MB)

@arnoldbeilandevozon

I have created a ticket with ID PSDNET-712 in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Hi,
do you have any estimate when this will be available - we have these issues for multiple release already.
Regards

We found another file with the same problem. Can you please update the ticket you created and add this one as well?

Thanks

sample2.zip (4.1 MB)

@arnoldbeilandevozon

I have added the information in our issue tracking system and will share the good news with you as soon as the issue will be fixed.

If you’ve figured out what’s the problem could you give us a workaround to be able to open the file until fix is available? By workaround I mean changing some properties on a layer or other things that are causing the problems?

We need it as the original file is extremely important and we need to provide a workaround asap. Thanks.

@arnoldbeilandevozon

The issue is in progress and we hope to resolve this as soon as possible. As soon as it will be fixed, it will become part of our next release.