We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Render speed with gridlines on

Hi,


We have noticed that when a page is rendered in cells 7.0+ via sheet-to-image and gridlines are switched on the render takes much longer than it does if they are switched off. This did not happen in the 3.n releases.

Could you please check if anything can be done to improve this as large sheets take an unacceptable time to render.

Regards,
Henrick

Hi,


Please try our latest version v7.1.0:
http://www.aspose.com/community/files/72/java-components/aspose.cells-for-java/entry355902.aspx

If you find any significant difference in timings, paste your sample code (runnable) and attach your template files here, we will check it soon.

Thank you.

Hi,


I’ve tried this with the latest release and the differences in timings are quite significant:

Render time with gridlines on: 1349405470
Render time with gridlines on: 477382172
.
.
Render time with gridlines on: 439057035
Render time with gridlines on: 445232090
Elapsed time with gridlines on: 18719807507
Render time with gridlines off: 155030002
Render time with gridlines off: 154957063
.
.
Render time with gridlines off: 156197424
Render time with gridlines off: 149540974
Elapsed time with gridlines off: 6132876144
Done

Code and spreadsheet are attached.

Regards,
Henrick

Hi,


Thanks for the sample file and code.

After an initial test using your code snippet, I can notice the performance goes down with grid lines on for Sheet-to-Image feature. I have logged a ticket with an id: CELLSJAVA-40136. We will look into it soon. Once we have any update, we will let you know here.

Thank you.

Hi,

We have improved the rendering speed for gridlines, so please try this new fix (attached). Also, because some global(static) resources(such as fonts) need to be parsed and initialized when using rendering functions at first time and the initialization is a bit time consuming, so the first loop(with gridlines on) in your program will need more time than the second loop(with gridlines off). If you turn off gridlines in the first loop and turn on gridlines in the second loop, the difference between two situations may become smaller too.


Thanks for your understanding!

Thanks for the speedy fix. Gridlines render a lot quicker now.

Hi,


Thanks for your feedback.

Good to know that your issue is resolved.
Have a good day!

The issues you have found earlier (filed as CELLSJAVA-40136) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.