We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Reporting services - Export to CSV (ACCSV) encoding issues

Hi

Can you please double check that the roll back was done successfully in version 22.10.4 ?
I tried to decompile the DLL and I see some differences, not sure I am doing this the right way but it seems that there are still some differences

@hengert,

Yes, apparently, the roll back was done properly.

Could you please share more details and the significant difference you found.

@hengert,

Please try Aspose.Cells.ReportingServices 22.10.1
without digital signatures
(6.0 MB).

Hi @wangtao

Thank you.

Report Server can now start without any issue but I still have the issue with the special characters.

@hengert,

We will go on fixing issues from the branch.

@hengert,

Please try the fixed version.Aspose.Cells.ReportingServices.2016.22.10.6.without digital signatures.zip (6.0 MB) only adds a feature about encode conversion.

Hi @wangtao

The DLL is recognised.

What do you mean by “feature about encode conversion” ?
Do you mean the handling of the special characters (with encoding = “Unicode”) ?

I’ve tried and the special characters are still unhandled.

@hengert,

We will get back to you soon.

@hengert,

We fixed the issue. Please try Aspose.Cells.ReportingServices.2016.WithoutDigitalSignatures.22.10.7.zip (6.0 MB).

@wangtao

Thank you, the version 22.10.7 is perfect and is working as expected.

Did you figured out what was the issue ? And why we had the issue with “cannot load assembly” ?

Would it be possible to have this version with digital signature just to be 100% sure it is not one of the root cause of the issue we faced with all previous versions ?

(I guess when you will release it, it is going to be with digital signature)

@hengert,
Yes. We will build a new version with digital signature for the issue. Now, we compared two branches with git, and there is not much difference except for fixing the encoding conversion part. We will further confirm the cause of the issue.

@hengert,

Please try Aspose.Cells.ReportingServices.2016.WithDigitalSignatures.22.10.7.zip (6.0 MB).

Hi

Thank you for the last release with digital signature

I confirm this is working

@hengert,

Thanks for your feedback.

Good to know that your issue is sorted out by the new fix/version. Feel free to write us back if you have further queries or comments, we will be happy to assist you soon.