We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Reporting services - Export to CSV (ACCSV) encoding issues

Hi

We are running Aspose Cells ReportingServices (version: 22.8.0.0) DLL on a PowerBI Report Server (Version1.14.8179.37378(May 2022)).

We are not using the native solution provided by Microsoft as it does not allow us to use custom headers containing hyphen (e.g.: “Textbox-1”).

Aspose Cells solves our issue with the headers but is creating an issue that we are not facing with the native rendering extension from Microsoft. It does not handle some special character such as “ü” or “ø”. It is replaced by the following �

The setup of the encoding in the rendering extension is set to “UTF-8”.

Is this a bug with the tool or did i do something wrong ?

Thank you in advance for your help

@hengert,

Could you please post your sample RDL file and exported CSV file here. Also, zip and attach Aspose.Cells.ReportingServices.xml file for reference. We will check your issue soon.

Hi

Thank you for your help.
When you say Aspose.Cells.ReportingServices.xml I guess you are referring to the rsreportserver.config file, right ?

Here is the rendering extension section

  <Extension Name="ACCSV" Type="Aspose.Cells.ReportingServices.CSVRenderer,Aspose.Cells.ReportingServices" Visible="true">
    <OverrideNames>
      <Name Language="en-US">CSV Aspose (semicolon)</Name>
    </OverrideNames>
    <Configuration>
      <DeviceInfo>
        <OutputFormat>CSV</OutputFormat>
        <Encoding>Unicode</Encoding>
        <Toolbar>False</Toolbar>
        <FileExtension>csv</FileExtension>
        <NoHeader>False</NoHeader>
        <FieldDelimiter xml:space="preserve">;</FieldDelimiter>
      </DeviceInfo>
    </Configuration>
  </Extension>

test.zip (1.7 KB)

Please find here also the 2 sample files

@hengert,

Thanks for the sample RDL file and output CSV file.

When you install Aspose.Cells for Reporting Services via its MSI installer, Aspose.Cells.ReportingServices.xml will be installed automatically at your installation folder.

Anyways, it looks like a configuration issue but we need to evaluate it thoroughly. I have logged a ticket with an id “CELLSRS-656” for your issue. We will investigate and figure it out soon.

Once we have an update on it, we will let you know.

Hi @Amjad_Sahi

I have not used the installation via MSI installer but via DLL only and only for Reporting Services the services component

@hengert,

Thanks for providing further details.

We have logged it with your existing ticket “CELLSRS-656” into our database.
Once we have new information (available) on your issue, we will update you.

@hengert,
We tested your provided report and didn’t reproduce the issue.
Please refer to the following configuration to set the logger level to debug in Aspose.Cells.ReportingServices.xml.

   <logger>
     <level value="Debug"/>
   </logger>

Please post Aspose.Cells.ReportingServices.log here and we will check it ASAP.

PS:

  1. Aspose.Cells.ReportingServices.log is in Aspose.Cells for Reporting Services installation folder.
  2. If you don’t find the log file, please check the writes right of the installation folder.

@hengert,

Please try to set the value of Encode to Unicode in the configuration file.

  <CSVRender Mode="Default">
    <encode value="Unicode"/>
    <Delimiters value=","/>
    <RenderTableList value ="False"/>
    <report name="" Mode="" encode="" Delimiters="" RenderTableList=""/>
    <NoOutPutIsValid ALL="False"/>
  </CSVRender> 

PS:
The configuration file is Aspose.Cells.ReportingServices.xml.

@wangtao

I will do it and provide you the logs.
In the meantime I have tried again with a different version of the RDL and I have exported the report using ACSV, ACXLS and CSV (the native rendering extension from Microsoft) and I confirm they are all rendering with the correct characters except ACSV.

I have attached the new RDL and the 3 output to see the difference.

Here is the rendering extension configuration I used

<Extension Name="CSV" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering" />	  
<Extension Name="ACXLS" Type="Aspose.Cells.ReportingServices.XlsRenderer,Aspose.Cells.ReportingServices" visible="true" />
<Extension Name="ACCSV" Type="Aspose.Cells.ReportingServices.CSVRenderer,Aspose.Cells.ReportingServices" />

Test Aspose.zip (3.0 KB)

I don’t have the Aspose.Cells.ReportingServices.xml as I did the installation with DLL Only.

I don’t have enough privilege on the server to do the installation, and our security policy does not allow us to install third parties tool using MSI installer

If doing the same in the rsreportserver.config is the same, I have already tried with and i had the same issue

If you are not able to reproduce the issue with the RDL i provided, can you try with the DLL installation only ?

@hengert,

Thank you for your detailed information.
We have gained important information from it.
We will rebuild the simulation environment in order to reproduce the problem.

@hengert,
We reproduced the issue and start to fix it.
We plan to release the 22.10 version which fixes the issue on Fri.

@wangtao

Thank you for your prompt support, much appreciated.

@hengert,

You are welcome.

@hengert,

Please tell us your MS Reporting Services version.

We are using Reporting Services 2017

@hengert,

Thanks for version details.

We will be looking into it soon.

Do you have an estimate on when this will be delivered ?

Thank you

@hengert,

As we told you, hopefully, we will publish the fixed version before the end this week.