Request response not active on appointment (Java)

With Aspose.Email for Java 19.2, when I create a new appointment, the option “Request response” is not active.
Attendees can not answer …
How to enable this option when creating the appointment by Java code?
Thanks !!!


I have observed your requirements and suggest you to please visit this documentation link for your kind reference. If you still have any inquiry then please provide the working sample code along with details of requirements in the form of required output with us.


// Les attendus : la salle de réunion
MailAddressCollection attendus = new MailAddressCollection();
MailAddress salle = new MailAddress(salleDeReunion.getMail(), salleDeReunion.getTitle());
// Construction du RDV
Appointment monRdv = new Appointment(salleDeReunion.getTitle(), null, null, null, attendus);	

// Construction du message
AlternateView view = monRdv.requestApointment();
MailMessage mail = new MailMessage();

// Sauvegarde OFT
String oftFileName = "test.oft";
MsgSaveOptions options = new MsgSaveOptions(MailMessageSaveType.getOutlookMessageFormatUnicode());
options.setSaveAsTemplate(true);, options); 

The appointment :
image.png (49.7 KB)

The request :
slight_smile:image.png (15.2 KB)

I want a response from the attendees…

Thanks !!!


I have worked with the sample example shared by you and output OFT file does not seem to have option for Request Response set. An issue with ID EMAILJAVA-34551 has been created in our issue tracking system to further investigate the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Hello @mudassir.fayyaz,
do you have a delivery date for this issue please ?
It is becoming urgent…
Thanks !


We have internally investigated the issue in detail. We need to use KnownPropertyList.ResponseRequested property:

MapiMessage msg = MapiMessage.fromMailMessage(mail);
// Save the appointment as draft.
msg.setProperty(KnownPropertyList.ResponseRequested, true);
String oftFil
eName2 = "C:\\Email\\test2.oft";;
1 Like

It works !!
Thanks !


It’s good to know things are fine on your end. Please feel free to share if any further help is required from our side.