We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Resetting Number List Problem

The attached XML Word doc shows a problem we encounter ending numbered lists. In Microsoft Word you should notice that each of the three lists restart at 1. I used Aspose.Word to convert the document to PDF. In the converted document the second list correctly resets to 1, but the third list does not. Instead it continues on to 9.

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your reporting this to us. I managed to reproduce this problem. I have created new issue #5177 in our defect database. I will notify you as soon as it is fixed.

Best regards.

Any progress or time estimate

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. This issue is already resolved in our code base. The hotfix is expected within 2-3 weeks. I will notify you as soon as it is published.

Best regards.

The issues you have found earlier (filed as 5177) have been fixed in this update.

I tried the new version, but still doesn't seem to work. See the attachment.

Hello!<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for reporting this.

Looking inside I figured out that reason of this issue is different. We’ll also try to fix it. But I’d like to note this case is strange. There are three lists in the document. You can see this by selecting labels of individual items. MS Word will show other items of the same list. There is some MS Word magic with numbering restarting within one list. This is currently not supported. You can overcome the issue by splitting to more lists. But would you tell me why you practically need such a strange list? Maybe things could be made easier.

I have created a new issue #5949 for this case. It should be investigated and I cannot promise you a quick fix. Let’s consider document refactoring if it’s possible for you.

Regards,

We are happy to tell you that we released new version of Aspose.Words. This version includes fix of issue you found earlier (issue # 5949). You can download new version from here:<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

http://www.aspose.com/community/files/51/file-format-components/aspose.words/entry154627.aspx

Best regards.

Still having problems. See attached document.

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. I managed to reproduce the problem in my side and created new issue #7123 in our defect database. I will notify you as soon as it is fixed.

Best regards.

Any news regarding this issue?

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Unfortunately, the issue is still unresolved. I will notify you as soon as I have any news regarding this issue.

Best regards.

The issues you have found earlier (filed as 7123) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.