We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

RGB color format not working with Text

Hello,


We are using Aspose.Words 9.0 to generate reports. While printing text output using we are facing problem with font color setting for some of the languages.

e.g. We are generating report in Arabic language and we have set the font color to “255,128,128” and the document fails to print.

While same works well for English language report.

Error screen dump is attached.

Also some of the non-working font colors are also attached in a document.

Please take a look at error dump and let us know.

While color provided with name “Red”, “Black”, “Pink”, “White” works well for all languages.

Regards,
Dwarika

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Could you please provide me more information, what should I do to reproduce the problem on my side? Could you please try using the latest version of Aspose.Words 9.1.0 and let me know how it goes on your side?

Best regards,

Hi,


Some more information on RGB colours. When the RGB colour works well for report language english.
It is giving problem for language like Arabic and many more. But i am testing Arabic that is why i have mentioned it.
Attached is the Font Object detail when Report language is English and Arabic.
Take a look at it and let us know whether there is a problem with language locale id?
also the colour used to get this object details is attached.

Regards,
Dwarika

Hi Dwarika,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. But it is still not clear how we can reproduce the problem. Could you please create a simple application, which will allow to replicate the problem? Also step-by-step guide could be useful. We will check the issue and provide you more information.

Best regards,