Free Support Forum - aspose.com

Root element is missing

Hi guys,

The enclosed file returns the error message "Root element is missing" when I try to instantiate it from a stream. I convert many files routinely however this one seems to be having a problem. The code looks a bit like this:

Memory stream m = new MemoryStream(fileBytes);
Aspose.Words.Document d = new Aspose.Words.Document(m); <- XmlException, the root element is missing

There is nothing wrong with my license file and most other documents work correctly.

Please help, as this intermittent error still affects significant proportion of my documents and it is causing a lot of problems.

Hi,


Thanks for your inquiry.

While using the latest version of Aspose.Words i.e. 11.7.0, I managed to reproduce this exception on my side. I have logged this issue in our bug tracking system. The issue ID is WORDSNET-6977. Your request has been linked to this issue and you will be notified as soon as it is resolved. Sorry for the inconvenience.

Best Regards,

Hi guys,

Is there any news on this? Our operation involves tens of thousands of documents and this is problem is becoming increasingly burdensome. I’d appreciate if you could let me know the status and a likely ETA if its available.

We appreciate the help.

Hi,


Thanks for your inquiry. Good news for you is that your issue (WORDSNET-6977) has now been resolved and its fix will be included in the next version of Aspose.Words (v11.8.0). We will inform you as soon as the new release is published.

Best Regards,

The issues you have found earlier (filed as WORDSNET-6977) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.