We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

RTF Text Columns not converting to Word or PDF and other layout issues

Hi, we recently purchased Aspose Words and are having layout issues when trying to convert a RTF file to PDF and/or Word Doc that has 2 text layout columns. I have attached the initial RTF file and PDF generated by Words, (the Doc looking the same).


Now if I open up the RTF file directly in Word, it displays correctly. If I convert the RTF file with a program like CutePDF it generates correctly.

Other less complex RTF files we have tried with Aspose works well.

Do you have any suggestions or advice as to how we can get this working.

thanks

– edit - I should also mention the initial RTF file was generated by another tool, not Aspose or directly from Word.

Hello,

Thank you for your request.
I managed to reproduce your problem on my side. I have registered an appropriate issue in our database of defects. Once the problem is solved, we will notify you immediately.

Hi Rumata,

Can you please give us an update on progress on this bug? Being able to pdf this report was a key reason we bought licenses for your product and it’s holding up a release at our end.

Best Regards,

Colin

Hello,

Thank you for your request.
Unfortunately, your problem has still not analyzed by developers. We will keep you informed of any developments of this issue. I will add your request in my monthly report. This will increase the priority of the problem.

Thanks Victor,

So is it fair to say that a fix is at least a month away?

We’d be happy with a suggestion for a workaround at this stage - does Aspose generally not handle columns / column breaks well?

Best Regards,

Colin

Hello Colin,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. If you try open/save your document in MS Word and then convert to any format using Aspose.Words you will get the correct output. As you said, this document was created using some external tool. So it means that there is something wrong with your document and upon saving MS Word fixes this. MS Word corrects the document during open/save.

So as a workaround of this problem you can try using Aspose.Words to create this document from scratch or you can open/save your document in MS Word and then process this document with Aspose.Words.

Best regards,

The issues you have found earlier (filed as WORDSNET-4730) have been fixed in this .NET update and in this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.