We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SaveAs produce bad rendering

Hi,

I'm evaluating your software to produce automatically some documents. I have a dotx with many bookmarks and I remove some section according to business code to produce a custom form in XPS or Tiff. When I saveas to docx format, it works, but when I saveas to XPS or Tiff format, the rendering is not accurate. I have some verticaL lines on the result file. See attachment to see output result.

Thank you

Steve

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Could you please attach your input and output documents here for testing? I will investigate the issue and provide you more information.

Best regards,

Hi,

Here are the documents. The .dotx is the source document and the docx and xps are the destination files.

Thanks

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is fixed.

Best regards,

Hi,

Any news on that bug? We needs to choose a third party right now and we cannot go with you with this bug. I need an answer please...

Thank you

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Unfortunately, the issue is not yet resolved. If you have control over your template, you can easily solve the problem by clearing formatting of tables (where unnecessary border is shown). After clearing table formatting, the document is rendered properly.

Best regards,