Free Support Forum - aspose.com

SaveToImage not saving checkbox fields correctly when called from a webservice running on a server

I have a webservice that is used to open a word document that is stored in the database as an image and save this document as a tif. My webservice is using the same class as my windows application and the windows application can save the document as a tif using SaveToImage and the checkbox fields are saved correctly. If I run the webservice on my development machine the image is saved correctly. If I run the webservice from our development server then the image does not save the checkbox fields correctly. This would indicate to me that the server is lacking something that Aspose needs to save the image correctly.

I have attached the word document(ExtractCaseMinuteView.Doc) that we are trying to save as a tif. I have also attached the tif that is saved from the webservice running on my machine(savedFromMyMachine.tif) and the one saved from the development server (SavedFromServer.tif).

The issue is how the checkbox fields are being saved, the server version squishes the checkbox so that you cannot see if the checkbox is checked or not.

I am using Aspose.Word 6.4. I have also tried Aspose.Word 8.2.1, both produce the same result.

The code used to save the image is:

Dim lobjImageOption As New Aspose.Words.Rendering.ImageOptions

lobjImageOption.TiffCompression = Aspose.Words.Rendering.TiffCompression.Ccitt4

lobjImageOption.Resolution = 200

For liPageNo As Integer = 0 To mobjMainAsposeDoc.PageCount - 1

mRequestGUID = Guid.NewGuid

lsFileName = lsAsposeImageSaveLocation & mRequestGUID.ToString & ".TIF"

mobjMainAsposeDoc.SaveToImage(liPageNo, 1, lsFileName, lobjImageOption)

Next

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Please make sure that Wingdings 2 font is installed on the Server where you perform conversion to image. If not, please try to install Wingdings 2 font. This should fix the problem. Please let me know in case of any issues.

Best regards,

Installing WingDing 2 fixed the issue. Thanks