We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SaveToImage not saving table correctly

Aspose 6.4 can perform a SaveToImage and produce a .tif that mimics the original document. I upgraded to Aspose.Word 8.2.1 and the same document saved as tif will not correctly save the table.

I have attached the word documents and the 6.4 tif and the 8.2.1 tif.

You will see that the 6.4 tif displays Christopher Payton under the VS and the 8.2.1 tif does not.

Hi Jody,

I was unable to reproduce the issue using the Aspose.Words 8.2.1 DLL files. Both rendered images are identical to the documents you attached.

Could you please post the code that you are using here?

Thanks,

Here is the code used to save the image

Dim lobjImageOption As New Aspose.Words.Rendering.ImageOptions

lobjImageOption.TiffCompression = Aspose.Words.Rendering.TiffCompression.Ccitt4

lobjImageOption.Resolution = 200

If Directory.Exists(System.IO.Path.GetTempPath & "VerdictPrintTemp") = True Then

mobjMainAsposeDoc.Save(System.IO.Path.GetTempPath & "VerdictPrintTemp\" & "ExtractCaseMinuteView.Doc", SaveFormat.Doc)

End If

For liPageNo As Integer = 0 To mobjMainAsposeDoc.PageCount - 1

lFilePageNo = lFilePageNo + 1

mobjMainAsposeDoc.SaveToImage(liPageNo, 1, System.IO.Path.GetTempPath & "VerdictPrintTemp\" & "ExtractCaseMinuteView" & lFilePageNo.ToString & ".TIF", lobjImageOption)

Next

Please attach your tif so that I can compare.

Hi Jody,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I cannot reproduce the problem on my side using the latest version of Aspose.Words (9.1.0). You can download this version from here:

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/category1188.aspx

I used the same code as you provided.

Best regards,

Are you able to reproduce this issue on 8.2.1? this is the last version I am able to use without purchasing a new subscription.

Please attach the tif you saved so that I can compare the results.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I cannot reproduce the problem using Aspose.Words 8.2.1 too. Please see the attached files.

Best regards,

So you can't recreate this issue but why is it if I run my app uisng 6.4 my image is saved correctly but when I change to 8.2.1 it is not.

Please provide the code you used to open and save this document as a tif.

My application is building an Aspose document, I then use this document to SaveToImage. I also save the Aspose document as a .doc to use later for troubleshooting. The .doc document is what I sent you, so I started thinking that maybe this is working for you because you are opening the saved Aspose document, so I have changed my code to open the saved.doc file and then use this document for the SaveToImage and the image works correctly in 8.2.1.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

This means that there must be something wrong in the Aspose Word document itself that the SaveToImage cannot handle correctly based on what version I am using, but saving as it as a.doc document and then opening that document and saving as a tif fixes the problem.

Any thoughts on this?

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I use the following code for testing:

Document doc = new Document(@"Test\Aspose8_2_1.Doc");

ImageOptions imageOption = new ImageOptions();

imageOption.TiffCompression = TiffCompression.Ccitt4;

doc.SaveToImage(0, doc.PageCount, @"Test\out.tif", imageOption);

Also, could you please create simple application, which will allow me to reproduce the problem on my side? I will check it and provide you more information.

Best regards,

Hi Jody,

I'm afraid both my colleague and I are unable to reproduce the issue. I have tried it in VB as well but both outputs appear correctly. My recommendation it to try deleting the table that is causing the issue and remaking it, this may just solve the problem.

Thanks,