Free Support Forum - aspose.com

Saving as GLB doesn't Include linked Assets

Hi,

I am trying to convert .gltf to .glb according to the examples given for opening a scene and saving it.
If the Output folder path is not same as the Source file, the linked textures doesn’t get included in the .glb exported. It does pack them if the Textures are in the same folder as the .gltf file and output .glb file path is also the same folder, but it doesn’t pack them when the textures are in a subfolder too, even when the output folder for.glb is same as .gltf.

I have tried playing around with save options and “EmbedAssets” seemed like the thing to do this but it has no effect here.

Can you please let me know if there is anything I am doing wrong here.

One more thing is when I use https://sbtron.github.io/makeglb/ tools like this to pack gltf to glb the file size is almost the same as the assets combined but when I save glb from aspose3d lib. the resulting .glb is almost 3 times bigger than the assets size combined.

@shohair

Thank you for contacting support.

Would you please create a narrowed down sample application reproducing the problem so that we may try to reproduce and investigate it in our environment. Also share respective source and generated files so that we may proceed to help you.

Before sharing requested data, kindly ensure using Aspose.3D for .NET 18.11 in your environment.