We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Scene.Save( filename, FileFormats.FBX7400 ) Doesn't use compression

Hi

I’ve noticed a change in behavior that I’m not sure is intentional.

The following line:

scene.Save( saveDialog.FileName, FileFormat.FBX7400Binary );

saves to fbx files that are significantly larger than the input. When switching to:

scene.Save( saveDialog.FileName, new FBXSaveOptions( FileFormat.FBX7400Binary ) );

the file is at a more reasonable size. It seems like FBXSaveOptions defaults to Compression on, and using the FileFormat.FBX… defaults to compression off.

I believe using the FileFormat overload with fbx did not disable compression in the past.

@bortos

Thank you for contacting support.

Please note that EnableCompression property was added to FBXSaveOptions class in Aspose.3D for .NET 18.10 for which default value is true. You may refer to API Changes section in Release Notes for your kind reference.

Hi Farhan

Yep, I got that.

It’s just a bit confusing that the other overload:


does not use compression by default, when I think it use to previously.

e.g.

Scene.Save(“Fred.fbx”, new FbxSaveOptions(FileFormats.FBX7400Binary))
and
Scene.Save(“Fred.fbx”, FileFormat.FBX7400Binary)

should produce the same output, but the former has compression enabled, and the latter does not.

If I’m wrong, please disregard post :slight_smile:

@bortos

Thank you for getting back to us.

Please note that each overload does not use compression by default. So the results you are getting are as expected.