Free Support Forum - aspose.com

setLicense not working:

Hello,

We have a Aspose.Total.Java license.

When I try to set the license for the pdf-kit(4.4.0), it works:

com.aspose.pdf.kit.License licensePdfKit = new com.aspose.pdf.kit.License();
licensePdfKit.setLicense(asposeLicenseFileLocation);
However, when I try to set the license for the Slides(6.9.0), it does not work:

com.aspose.slides.License licenseSlides = new com.aspose.slides.License();
licenseSlides.setLicense(asposeLicenseFileLocation);
The following exception is thrown:

com.aspose.slides.AsposeLicenseException: Couldn’t parse black list. Please report this error to Aspose.
at com.aspose.slides.LicenseController.try(Unknown Source)
at com.aspose.slides.LicenseController.if(Unknown Source)
at com.aspose.slides.LicenseController.setLicense(Unknown Source)
at com.aspose.slides.License.setLicense(Unknown Source)
at com.aspose.slides.License.setLicense(Unknown Source)

Caused by: java.lang.NullPointerException
at com.aspose.slides.c.a.e.D.do(Unknown Source)
at com.aspose.slides.c.a.g.b.do(Unknown Source)
… 26 more

Any idea what might be wrong?

Hi,


I have observed the stack trace shared by you. Can you please confirm on your end that if your subscription is valid for Aspose.Slides for Java 6.9.0 as it has been released on 11 January, 2013. If your subscription has expiry date after the mentioned date then please share the license file with us by following the guidelines shared over this link. I will investigate the issue further on my end to help you out.

Many Thanks,

Hi,


Thanks for sharing the license file. I have worked worked with the license file shared by you and have not been able to reproduce the issue specified using Aspose.Slides for Java 6.9.0 in Windows environment using JDK 1.6_27.

Can you please share the sample java file along with the complete environment details on your end so that I may investigate it further to help you out.

Many Thanks,