We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Setting the tab color for tabs in GridDesktop

When I import an Excel file and display it in Aspose.Cells.GridDesktop, the tab colors of the file are not shown in the Aspose control and the colors are always default one. Can you please let me know how I can set or override them?

@stadie,

Please notice, I am able to reproduce the issue as you mentioned. If an Excel file has tabs (with different colors set). When importing the file to Aspose.Cells.GridDesktop, the colors are not rendered. Also, when setting the tab colors manually in code (e.g. gridDesktop1.Worksheets[0].TabColor = Color.Red;), it does not work either. We have logged a ticket with an id “CELLSNET-49067” for your issue. We will look into it soon.

Once we have an update on it, we will let you know.

Please try our latest version V21.9 ,It is fixed

Thanks for fixing that.

@stadie,

Please get latest Aspose.Cells.GridDesktop v21.9 from Aspose.Cells for .NET v21.9 package using any of the following modules:

  1. Downloads section
  2. Nuget repos.

Hope, this helps a bit.

@stadie,
This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

The issues you have found earlier (filed as CELLSNET-49067) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao