Free Support Forum - aspose.com

Shape content does not change in scaled shape thumbnail (C# .NET)

I am trying to extract the shapes as png images, and the quality is not good as MS although I am saving the image as png. so I tried to scale it up by calling shape.GetThumbnail(Aspose.Slides.ShapeThumbnailBounds.Shape, 2.0f, 2.0f)), but the image size was changed but the content remains the same. is there any functionality that let me scale the shape before calling GetThumbnail, I don’t want the content to be rasterized.

Hi Andrew,

I have observed the requirement shared by you and request you to please share the source presentation, extracted images and sample code used. I will investigate the issue on my end to help you further in this regard.

Many Thanks,

Thanks,



Attached zip file contains, all you need to reproduce this issue,



Thanks in advance :slight_smile:

Hi Andrew,

I have worked with the presentation file shared by you and have been able to observe the effect that when generating the scaled shape thumbnail, the text remains the same and is not scaled. An issue with ID SLIDESNET-35673 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

Hi there. Is the issue still unresolved?

@obrusentsov,

I suggest you to please try using latest Aspose.Slides for .NET 19.1 on your end for generating scaled shape thumbnails. With latest version and previously shared customer information, I am unable to reproduce the issue.