We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Shapes not represented properly in gridweb

dear support.


Thank you for your great product.

I have attached an Excel spreadsheet that I want to load in a gridweb.
The spreadhseet contains shapes with lines between them.
Unfortunately, the shapes do not line up properly when loaded in the gridweb - their location is different than in the original excel file.

thank you

guido


Hi Guido,

Thanks for your posting and using Aspose.Cells for GridWeb.

We were able to observe this issue using the latest version: Aspose.Cells.GridWeb v7.0.0.2000. The shapes are not rendered properly.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-42509.

I have attached the screenshot highlighting the issue for a reference.

Screenshot:

Hi,

Thanks for using Aspose.Cells for GridWeb.

Please download and try the latest fix: Aspose.Cells
for GridWeb v7.0.1.2001
and let us know your feedback.

the latest verison of Gridweb v7.0.0.201 does not seem to resolve the porblem.

Objects are stoill placed differently.

guido

Hi Guido,

Thanks for your posting and using Aspose.Cells.

Aspose.Cells
for GridWeb v7.0.1.2001
is working fine. Please see the screenshot for your reference.

well it doesnt work on my side

i am 100% sure I am using the latest dll v7.0.0.2001

code is deadsimple :
Protected Sub Page_Load(sender As Object, e As EventArgs) Handles Me.Load

REM general stuff
Dim licenseweb As New Aspose.Cells.GridWeb.License

REM exit of callback
REM If IsPostBack Then Exit Sub

REM set licenses
licenseweb.SetLicense(“F:\Aspose Licenses\Aspose.Cells.lic”)

REM initial setting for gridweb behaviour
GridWeb1.ACWClientPath = “F:\acw_client”
GridWeb1.Width = New Unit(1000, UnitType.Point)
GridWeb1.Height = New Unit(600, UnitType.Point)
GridWeb1.WebWorksheets.Clear()
GridWeb1.WebWorksheets.Add()
GridWeb1.WebWorksheets.ActiveSheetIndex = 0
GridWeb1.ShowSaveButton = False
GridWeb1.ShowUndoButton = False
GridWeb1.NoScroll = False
GridWeb1.EnablePaging = False
GridWeb1.ShowContextMenu = True
GridWeb1.EditMode = True
GridWeb1.ForceValidation = False
GridWeb1.ShowBottomBar = True
GridWeb1.ShowHeaderBar = True
GridWeb1.MaxColumn = 10
GridWeb1.MaxRow = 10
GridWeb1.WebWorksheets.Clear()

REM add file
GridWeb1.WebWorksheets.ImportExcelFile(“F:\MWorks_CauseEffect\Report.xlsx”)

End Sub

Hi Guido,

Thanks for your posting and using Aspose.Cells.

Kindly provide us your sample project replicating this issue. It will help us investigate this issue appropriately and if we find any issue, we will report it to development team for a fix.

Hi Guido,

Sorry, the link text was wrong, you are using the right version i.e 7.0.0.2001.

Could you please provide the sample project so that I could run or test it at my end?

please find attached the Visula studio code.

There is nothing special about the code.
please have a look and advise

guio



Hi Guido,

Thanks for your sample project and using Aspose.Cells.

It seems, the issue is occurring because Aspose.Cells for GridWeb is unable to find/use the path of acw_client directory. So I have commented this line

GridWeb1.ACWClientPath = "F:\acw_client"

and added these lines in Web.config file


<add key=“aspose.cells.gridweb.acw_client_path” value=“GridWeb/acw_client”/>




I also added the GridWeb and acw_client directories in the virtual directory. Please see the screenshot of the changes I made highlighted in red.

Please download the project and run it at your end to see the results now.

it now works perfect !!!

I have never seenm such a great support from any software vendor !!!
thnaks a lot.
I have never regretted having bought this !
guido

Hi Guido,

Thanks for your comments. We are pleased to know that everything is working good at your end too.

Let us know if you encounter any other issue, we will be glad to look into it and help you further.

The issues you have found earlier (filed as CELLSNET-42509) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

dear support,


I have loaded version 8.4 of the gridweb component and it seems my previous issue is reappearing. This seemed to work in earlier versions.

The problem is that the shapes are not located properly in the gridweb components.
I have appended my project, source excel file and a screenshot of the resulting webpage.

In a previous mail, you suggested to inlcude the path to the acw_client directory. I have done this, but this does not seem to resolve my problem

Also, it seems column A is sometimes disappearing - maybe this is related.

thanks for your much appreciated help.


Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

I have run your sample project and I got different results. I have attached the screenshots showing firefox and chrome results for your reference.

I have reopened this issue and added your comments inside it. Please spare us some time. Once, the issue will be fixed or we have some other update for you, we will let you know asap.

Hi,


Please try our latest version/fix: Aspose.Cells.GridWeb v8.4.0.1

We have fixed your issue now.

Let us know your feedback.