We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SheetRender does not correctly handle supercript styling when creating the output image

Hello,

We’ve discovered an issue with SheetRender, when applying it on a file containing a custom style.

I’ve attached a small console application describing the issue - the app loads the TestFile.xlsx and produces an image.png from the first sheet.

The test file has on Sheet1!A1 cell the “test (1)” value which is displayed by Excel with the (1) as supercript, due to a custom styling applied on the excel file. When using SheetRender to create the image, the (1) is not superscript anymore, but subscript. I’ve attached also the resulted image, for reference.

We are using Aspose.Cells version 8.0.1.0.

Any feedback will be highly appreaciated.

Thank you,
Mihai Andrei
Sr Software Engineer
IBM Romania

Hi,

Thanks for your posting and using Aspose.Cells.

We were able to observe this issue using the following code with the latest version: Aspose.Cells
for .NET v8.0.1.4
. Superscript is not rendered fine.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-42615.

I have attached the output image and screenshot of Excel for a reference.

C#


Workbook workbook = new Workbook(path);


Worksheet worksheet = workbook.Worksheets[0];


Aspose.Cells.Rendering.ImageOrPrintOptions options = new Aspose.Cells.Rendering.ImageOrPrintOptions();

options.OnePagePerSheet = true;

options.ImageFormat = ImageFormat.Png;


SheetRender sr = new SheetRender(worksheet, options);

sr.ToImage(0, path + “.out.png”);



The issues you have found earlier (filed as CELLSNET-42615) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hello,

We’ve tested against Aspose.Cells version 8.0.2.0 and the issue seems solved.

Thank you,
Mihai Andrei

Hi Mihai.


Good to know that you are up and running again. Please feel free to write back in case you need our further assistance.