We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SheetRender.ToImage not rendering cells border

Aspose.Cells 8.7.1.0 -> SheetRender.ToImage is not rendering cell's border correctly when cell content text oriented at 70 degrees (Format cell->Alignment tab->Orientation).
(see cell L3 of the provided Excel workbook's sheet named AAA).

You can use the provided code to reproduce the problem.

Here is a Snippet:
public void ProcessAllWorksheet()
{
foreach (Worksheet worksheet in workbook.Worksheets)
{
if (worksheet.IsVisible)
{
ImageOrPrintOptions imgOptions = new ImageOrPrintOptions();
imgOptions.ImageFormat = System.Drawing.Imaging.ImageFormat.Jpeg;

imgOptions.HorizontalResolution = 200;
imgOptions.VerticalResolution = 200;
imgOptions.OnlyArea = true;
imgOptions.OnePagePerSheet = true;

System.Drawing.Bitmap image = null;
try
{
SheetRender sr = new SheetRender(worksheet, imgOptions);
image = sr.ToImage(0);
}
catch (Exception ex)
{
Console.WriteLine("Error: {0}", ex.Message);
}

image.Save(string.Format("_{0}.jpeg", worksheet.Name), System.Drawing.Imaging.ImageFormat.Jpeg);
}
}
}

Hi,

Thanks for your posting and using Aspose.Cells.

We have generated the image with the following code and were able to observe this issue.

I have also attached the output image for a reference. The cell border is not rendered as highlighted in a red circle.

This issue has been logged as

  • CELLSNET-44302 - SheetRender.ToImage not rendering cells border

C#
Workbook workbook = new Workbook(“InputFile.xlsx”);

Worksheet sheet = workbook.Worksheets[“AAA”];

ImageOrPrintOptions opts = new ImageOrPrintOptions();
opts.OnePagePerSheet = true;

SheetRender sr = new SheetRender(sheet, opts);
sr.ToImage(0, “output.png”);

Hi,

Thanks for using Aspose.Cells.

This is to inform you that we have fixed your issue CELLSNET-44302 now. We will soon provide the fix after performing QA and including other enhancements and fixes.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.8.0.3 (attached).

We have fixed your issue “CELLSNET-44302” now.

Let us know your feedback.

Thank you.

The issues you have found earlier (filed as CELLSNET-44302) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hi,


Sorry for the delay.


Yes I confirm that it fixes my issue.

Thank you

Hi,


Thanks for your feedback.

Good to know that your issue is sorted out by the new version/fix. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

Thank you.