We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Simple PPTX generated with Aspose throwing error

Attached is a simple PPTX i generated with your component (version 7.1 for .net 4.0)


When it is opened it using PowerPoint 2010, the presentation throws the following error:
"PowerPoint found content in Playbook for Dmitri’s Test - v1.pptx that it did not understand.
This content has been removed and cannot be recovered."

All my code does is add a blank slide, add 4 images to the slide, and saves it as a PPTX

Hi Dmitri,


Thanks for inquiring Aspose.Slides.

I have observed the presentation file shared by you and have been able to observe the issue specified in presentation when opened in PowerPoint 2010. Can you please share the sample source presentation with us along with source code used to generate the presentation. I will try to reproduce the issue on my end to help you further.

Many Thanks,

The code i used to generate that sample is fairly complex BUT i have generated a new PPTX with the following code and it shows the same error (i attached the new PPTX here)


Here is the code:

Aspose.Slides.License lcs = new Aspose.Slides.License();
lcs.SetLicense(“Aspose.Total.lic”);

PresentationEx ppx = new PresentationEx();
ppx.Slides.AddEmptySlide(ppx.LayoutSlides[0]);
ppx.Save(Server.MapPath("~/Output/test.pptx"), Aspose.Slides.Export.SaveFormat.Pptx);

Hi Dmitri,


I have worked with the sample presentation shared and have not been able to observe the issue specified in generated presentation. For your kind reference, I have attached the generated presentation as well.

I have also observed that the message, " PowerPoint found the content…" in your source presentation is appearing. I have shared the snapshot of the opened presentation along with PowerPoint version. Can you please observe the issue further on your end as I have failed to reproduce the issue on my end.

Many Thanks,

Turns out it was still referencing the old Aspose.Slides dll (version 4. something). Once i got it to actually take the new version the issue went away (although my license is out of date apparently)

Hi Dmitri,


That is appreciable that you have been able to resolve the issue on your end. Please share, if I may help you further in this regard.

Many Thanks,