Free Support Forum - aspose.com

Single Quote from the Template column is missing in the output file

I have few Columns with a single quote so that it won't appear in the auto prefill in subsequent rows. But the single quotes are not there in the generated out put file after merge. Is there anything special that needs to be done to preserve the single quotes?

Could you please post a sample file and sample code to show your problem?

I checked this issue in MS Excel manually. If you input a single quote into a cell, MS Excel doesn't show it. But if you click that cell, it will show in the formula bar.

I have few cells with static text. In them like column headers. I have the test as ' Name with a single quote and space. In the merget out put it comes out as Name there single quote is not there.

If you want still want a sampel file I can post it.

Yes, please post your template file and output file created with Aspose.Cells here. Which version of Aspose.Cells are you using?

I have the latest version of aspose cells. I am uploading the template and the generated xls.

Thanks

It seems that if a string starts with single quote(’), MS Excel doesn’t save it in the file but saves some Asian phonetic information settings. Aspose.Cells doesn’t process these phonectic settings now which causes this problem. Is it possible to change your string from 'Number to "Number or even remove this starting single quote?