We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Slide Image Quality (HTML Conversion- Externally Linked Images)

Is there any way to get Aspose to save higher quality externally linked images when converting a powerpoint to HTML using the ILinkEmbedController approach? After the conversion I noticed that the images that eventually get saved and linked are a fraction of the size of the original image in the powerpoint slide. This results in a blurry image when it is rendered in HTML since the image is streched out to fit the size of the HTML slide. I’ve tried the following to no avail:


Aspose.Slides.Export.HtmlOptions options = new Aspose.Slides.Export.HtmlOptions(new LinkController(htmlImageFolder, htmlImageFolderUri));
Aspose.Slides.Export.SVGOptions svgOptions = new Aspose.Slides.Export.SVGOptions();
svgOptions.JpegQuality = 100;
svgOptions.MetafileRasterizationDpi = 600;
options.SlideImageFormat = Aspose.Slides.Export.SlideImageFormat.Svg(svgOptions);
options.JpegQuality = 100;
// options.HtmlFormatter = Aspose.Slides.Export.HtmlFormatter.CreateDocumentFormatter(string.Empty, false);
Presentation presentation = new Presentation(input);
presentation.Save(output, Aspose.Slides.Export.SaveFormat.Html, options);

Hi Lance,

Thanks for inquiring Aspose.Slides.

I have observed the requirements shared by you and request you to please share the source presentation generated HTML with us. Please share the requested information with us so that I may help you further in this regard. Before, sharing further information with us please try using latest Aspose.Slides for .NET 16.8.0 on your end as well.

Many Thanks,

I’ve attached the requested items. Thanks.

Hi Lance,


I have worked with presentation shared by you using Aspose.Slides for .NET 16.8.0 and unable to observe the issue. I request to you please use Aspose.Slides 16.8.0 version on your end. Please share feedback with us if there is still an issue. I have shared my generated output with you for your reference.
Please see attachments.

Best Regards,

Your output looks exactly like mine. I am using version 16.8.0. Can you see in the output that you generated that the images are less crisp and clear than in the original slides? That’s what I was trying to convey in my original message.

Hi Lance,

I have worked with the presentation shared by you using Aspose.Slides for .NET 16.8.0 and have been able to observe the issue. A ticket with ID
SLIDESNET-37923 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESNET-37923) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.