Free Support Forum - aspose.com

Smart mark rows question

I can't seem to figure out how to NOT insert rows when using smart markers. I have a very large worksheet with formulas at the column level (aways using current row). I've tried changing the formulas to use the &=&= and have mixed results. It works fine except in a few places where I don't want the formula printed for the first row.

I tried something like this:

A B C D
1 &=data.Field1 &=data.Feild2 Total: Old Way:
2 &=&=A{r}+B{r} =A2+B2
3 =A3+B3
4 =A4+B4
5 =A5+B5

But column C & D don't start at row 2, they will start after the data is loaded.

I'd like to just leave the hard coded formulas and have the designer NOT move my cells (it even updates my name ranges which is a another problem, but I'll save that for a different topic). Cam this be done???

Any help or ideas would be great!

thanks,
Jason

Hi Jason,

Please use noadd option.Such as &=data.Field1(noadd);

Please check the wiki http://www.aspose.com/wiki/default.aspx/Aspose.Cells/SmartMarker.html

Thank you for the speedy reply. This kind of worked, but I'm still having issues...

Using the &=data.field1(noadd) solves the problem of the cells references being updated but the cells themselves are still being moved to the bottom of the sheet...

My template looks like this:

A B C D
1 &=data.Field1(noAdd) &=data.Field2(noadd) Total: Old Way:
2 &=&=A{r}+B{r} =A2+B2
3 &=&=A{r}+B{r} =A3+B3
4 &=&=A{r}+B{r} =A4+B4
5 &=&=A{r}+B{r} =A5+B5

and results in this:

A B C D
1 data data Total: Old Way:
2 data data
3 blah blah
4 blah blah
5 =A2+B2 =A2+B2
6 =A3+B3 =A3+B3
7 =A4+B4 =A4+B4
8 =A5+B5 =A5+B5

How do I stop the columns C & D from moving??

Any help or ideas would be great!

thanks,
Jason

I think I solved my issue... Turns out there was a hidden column with a smartmarker and it didn't have the (noadd) flag... Changing that seems to have corrected the other columns.

thanks again for your help!