We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Smart marker - html - is throwing exception

Hi,
I’m trying to insert the smart marker as “HTML” (https://docs.aspose.com/cells/net/using-smart-markers/#using-html-property-of-smart-markers ) so the data will be rendered automatically.
but for some reason, I get a exception while processing the file,
image.png (11.8 KB)

may you can check this one? what is wrong with my template?
user status pdf excel - htmlrow.zip (276.0 KB)

attached template and data. I’m trying to set the “datarowa” property from the JSON (this is some test after the old property name was ContentAsHtmlTemplate and I thought maybe since this sounds as boolean maybe I got that error…

Edit. here some another try with a different template, I tried it in the column. this is printing the JSON instead of the data. not sure what I’m missing here. https://easyupload.io/tixown (zip with data, and exported pdf)
user status pdf excel html column.zip (9.6 KB)

@zivdaniel,

Thanks for the template file and resource files.

We will evaluate your issue and get back to you soon.

@zivdaniel
1, Please verify your json file is correct. Please check whether Double quotes is excepted before brackets in “reportDataRows”: "[
2,Html smart marker is used to input rich formatted text with html tag as abcd
Html smart marker can not process complex html string.

Hi,
in the first option, I took that to the next stage,
but on the second try, I’ve tried to send either
&=data.firstNameAsHTmlString
the value was: somename.
not sure this is complex HTML. the report printed the JSON instead of the values.

@zivdaniel
Please check the attached simple html smarker case.
Desktop.zip (14.4 KB)

Hi,
I did the same as you provided, in my template, but still I see JSON in the columns.
what is the different? my property looks like: &=data.employee.firstNameHtmlFormatting(HTML, copystyle,noadd)
this is the same as in the template you provided.
user status pdf excel html column.zip (645.2 KB)

Attached updated code

@zivdaniel,

Thanks for your template file, JSON data and output file.

We will evaluate it and get back to you soon.

@zivdaniel
Can you upload a runnable project, this seems to be a problem with parsing json。

Hi, I’ve changed the way of the structeing data
We used the multiple “branches” ( data.user.transactions.info.etc) and that cased probably the issue with the json.
so we changed the structure to be flated, which means now we have data.user_transaction_order_id
and this is work better. and the JSON is not presented.

@zivdaniel,

It looks like your issue is sorted out now. In the event of further queries or comments, feel free to write us back.