Free Support Forum - aspose.com

SmartMarkers and "number stored as text" warning

I am evaluating Aspose.Excel and am attempting to use SmartMarkers to load data to a spreadsheet. I have successfully gotten the data into the spreadsheet, but integer data imported via this method shows the "number stored as text" warning. I am aware that I can turn off this warning from the Excel Options page, but would rather have the value stored as a "number" value automatically.

I also have worked with the Aspose.Excel api call cell.PutValue() and know that using this api, I can cause the value to be converted to a different type by adding the "true" parameter.

Is there a way that this type of functionality can be accessed using the SmartMarker technique?

Thanks,

Pam

Currently it’s not supported in SmartMarker technique. We will make it in the future releases. Thanks for your suggestion.

Has this been implemented yet? I have an issue where we normally dump decimals into a column; however we have to store them as strings because certain scenarios force us to override the decimal value with “N/A”.

Hi,

Yes, it is implemented in new versions of the product. I have attached the latest version/fix for you to try it.

We have added “numeric” parameter for smart markers, all you need to do is place those smart markers with “numeric” parameter into the template file, e.g &=[Table1].Field1(numeric).

For complete reference, please see the topic: http://www.aspose.com/documentation/.net-components/aspose.cells-for-.net/smart-markers.html

Thank you.