We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SmartMarkers: (group:merge AND skip:1) don't appear to work together

Hi guys,

I think I’ve found something that used to work. I have a Smart Marker such as:

&=OppLineItems.PRODUCT_FAMILY(Group:Merge,Skip:1)

The problem seems to arise with the combination of “Group:Merge” and “Skip:1”. Individually, they’re fine, but together the “Skip” part doesn’t happen.

In Cells v7.7.1.0, the output looks like this:
http://screencast.com/t/ERcoMU2q
In this case, the grouping worked, but the “Skip” part didn’t work.

When trying the same operation using Cells v.4.8.1.3, the output looks like this:
http://screencast.com/t/QNlFft9WNNm
Here, the “Skip” functionality worked and there’s a blank row between the grouped data values.

I can put together a sample project if that would help to isolate this.

Thanks,

Michael

Hi Michael,

Thanks for your posting and using Aspose.Cells.

We were able to observe this issue. It seems smart markers group:merge and skip:1 together are not working. They individually works fine.

We have logged this issue in our database. We will look into it further and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-42371.

Hi,



Please try our latest version/fix: Aspose.Cells for .NET 7.7.2.

Please try the following codes with the attached file. Smart Markers (group:merge AND skip:1) works fine.<o:p></o:p>

e.g

Sample code:

internal static DataTable CreateDataTable()

{

DataTable dt = new DataTable("Order Details");

dt.Columns.Add("OrderID");

dt.Columns.Add("Quantity");

dt.Columns.Add("UnitPrice");

dt.Rows.Add(new object[] { 1, 20, 5.6 });

dt.Rows.Add(new object[] { 1, 20, 5.6 });

dt.Rows.Add(new object[] { 2, 30, 7 });

dt.Rows.Add(new object[] { 2, 30, 7 });

dt.Rows.Add(new object[] { 3, 25, 6.9 });

return dt;

// &=[Order Details].OrderID &=[Order Details].Quantity &=[Order Details].

}

static void Main(string[] args)

{

string filePath = @"d:\FileTemp\SmartMarker_Designer_2.xls";

DataTable dt = CreateDataTable();

Workbook workbook = new Workbook(filePath);

WorkbookDesigner designer = new WorkbookDesigner();

designer.Workbook = workbook;

designer.SetDataSource(dt);

designer.Process();

// workbook.CalculateFormula();

workbook.Save(@"D:\filetemp\dest.xlsx");

}


Let us know your feedback.


Thank you.

Hi Ahmad,

No, it’s not working for me, even with Cells 7.7.2.0.

I’ve attached a sample project to demonstrate.

Hi Michael,

Thank you for providing the sample project.

We are able to observe the problem using your project and sample spreadsheet, whereas the test case passes with Amjad’s provided code snippet and spreadsheet. We have attached your project with the ticket (CELLSNET-42371) already associated with this thread, and requested the development team to further investigate the problem cause. Please spare us little time to properly analyze the issue, and to provide a fix at earliest. In the meanwhile, we will keep you posted with updates in this regard.

Please accept our sincere apologies for your inconvenience.

Hi,

Thanks for your posting and using Aspose.Cells.

We have fixed this issue.

Please download and try the latest fix: Aspose.Cells for .NET 7.7.2.1 and let us know your feedback.

That’s working – thanks very much.

Michael

Hi Michael,

Thanks for your feedback and using Aspose.Cells.

We are glad to know that this issue is fixed in this latest version. Let us know if you encounter any other issue, we will be happy to look into it and help you further.

The issues you have found earlier (filed as CELLSNET-42371) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.