We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SMTP send list of split zip file to gmail account- only main .zip does not send out

Using smtp to send out a bunch of split zip files.
Refer to the attached screen shot, Files listed - DB41063.z02, …, DB41063.z71, DB41063.zip.
All the files z02 - z71 (file size 200kb) sent through, but final main DB41063.zip (200kb) fail to send.

Tried with following scenario:

  1. smaller split files - DB41063.z02(sent) and DB41063.zip(fail to send)
  2. no split file, only main DB41063.zip (sent)

This is the error returned:
ERROR;Exceeded storage allocation. The server response was: 5.7.0 This message was blocked because its content presents a potential
5.7.0 security issue. Please visit
5.7.0 http://support.google.com/mail/bin/answer.py?answer=6590 to review our
5.7.0 message content and attachment content guidelines. kw10sm3129306pab.29 - gsmtp

Hi BASS,


Thank you for writing to Aspose support team.

I tried the scenario by creating the split zip file containing 4 files, each 1,424 KB and fifth one of 646 KB. All the files are attached to the message and this message is sent using SmtpClient. I used my Gmail test account and found that the message is sent successfully and received properly as well.

It seems specific issue with the attachments you have used like if there is some exe which is added to zip file etc. Could you please send us the attachment files which are used for testing? It will help us to analyze the problem and provide assistance as soon as possible.

Hi,

Thanks for the prompt reply.

Here are the attachments.
BAS11235.z02, … BAS11235.zip.
Total file = 5

The contents of the zip file always contain documents and database - data file (.ado).
Executable file will not happen in this case.

Hi Bass,

Thank you for sharing your concern with us.

I was able to reproduce this issue at my end using the latest version of Aspose.Email for .NET 4.9.0 and have logged it as EMAILNET-34647 in our issue tracking system for further investigation by our development team. Once there is any information available in this regard, I'll update you here via this thread.

We are sorry for any inconvenience caused to you.

Hi,

Any updates for EMAILNET-34647 ?

Hi Bass,


This issue has been identified as not a bug at Aspose.Email end as per the expected behavior of the server as mentioned in this article. Please note that:
  • Gmail doesn’t allow you to send or receive corrupted files, files that don’t work properly.
  • Zip file within another zip file

In this case files in archive are interpreted also like archives and server is unable to open them.